Index: presubmit_canned_checks.py |
diff --git a/presubmit_canned_checks.py b/presubmit_canned_checks.py |
index e4ce0418c04ff0cc4645d9fbc2ba961710b53666..455a42f47dbe8f6f41b8c794bc81181bdd166c63 100644 |
--- a/presubmit_canned_checks.py |
+++ b/presubmit_canned_checks.py |
@@ -114,6 +114,14 @@ def CheckChangeLintsClean(input_api, output_api, source_file_filter=None): |
'-readability/casting,-runtime/int,-runtime/virtual,' |
'-whitespace/braces') |
+ # Replace <hash_map> and <hash_set> as headers that need to be included |
+ # with "base/hash_tables.h" instead. |
+ cpplint._re_pattern_templates = [ |
+ (a, b, 'base/hash_tables.h') |
+ if (header == '<hash_map>' or header == '<hash_set>') else (a, b, header) |
M-A Ruel
2013/04/12 23:22:13
and why not as I proposed earlier?
if header in ('
danakj
2013/04/12 23:29:14
Done.
|
+ for (a, b, header) in cpplint._re_pattern_templates |
+ ] |
+ |
# We currently are more strict with normal code than unit tests; 4 and 5 are |
# the verbosity level that would normally be passed to cpplint.py through |
# --verbose=#. Hopefully, in the future, we can be more verbose. |