Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(277)

Unified Diff: src/hydrogen.h

Issue 13985005: Separate calculation of double element and object element sizes in IsFastLiteral. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: Created 7 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « no previous file | src/hydrogen.cc » ('j') | src/hydrogen.cc » ('J')
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/hydrogen.h
diff --git a/src/hydrogen.h b/src/hydrogen.h
index f4f3752c83002d418e7534d65b349a991f3fb83a..15a447a22bb1f68064cc0f7d52a7e5a92ec913ff 100644
--- a/src/hydrogen.h
+++ b/src/hydrogen.h
@@ -1508,7 +1508,8 @@ class HOptimizedGraphBuilder: public HGraphBuilder, public AstVisitor {
HInstruction* BuildFastLiteral(HValue* context,
Handle<JSObject> boilerplate_object,
Handle<JSObject> original_boilerplate_object,
- int size,
+ int doubles_size,
danno 2013/04/12 08:15:38 how about using "data_space_size" and "pointer_spa
Hannes Payer (out of office) 2013/04/12 08:38:13 I renamed it to "data_size" and "pointer_size".
+ int objects_size,
AllocationSiteMode mode,
BailoutId id);
« no previous file with comments | « no previous file | src/hydrogen.cc » ('j') | src/hydrogen.cc » ('J')

Powered by Google App Engine
This is Rietveld 408576698