Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(166)

Side by Side Diff: components/view_manager/gesture_manager_delegate.h

Issue 1344573002: Mandoline: Rename components/view_manager to components/mus (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@master
Patch Set: Rebased Created 5 years, 3 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch
OLDNEW
(Empty)
1 // Copyright 2015 The Chromium Authors. All rights reserved.
2 // Use of this source code is governed by a BSD-style license that can be
3 // found in the LICENSE file.
4
5 #ifndef COMPONENTS_VIEW_MANAGER_GESTURE_MANAGER_DELEGATE_H_
6 #define COMPONENTS_VIEW_MANAGER_GESTURE_MANAGER_DELEGATE_H_
7
8 #include <set>
9
10 #include "components/view_manager/public/cpp/types.h"
11 #include "ui/mojo/events/input_events.mojom.h"
12
13 namespace view_manager {
14
15 class GestureManagerDelegate {
16 public:
17 // Informs the delegate of a pointer event. The delegate should asynchronously
18 // respond with the set of gestures appropriate for the view
19 // (GestureManager::SetGestures()).
20 // |has_chosen_gesture| is true if a gesture has been chosen.
21 virtual void ProcessEvent(const ServerView* view,
22 mojo::EventPtr event,
23 bool has_chosen_gesture) = 0;
24
25 protected:
26 virtual ~GestureManagerDelegate() {}
27 };
28
29 } // namespace view_manager
30
31 #endif // COMPONENTS_VIEW_MANAGER_GESTURE_MANAGER_DELEGATE_H_
OLDNEW
« no previous file with comments | « components/view_manager/gesture_manager.cc ('k') | components/view_manager/gesture_manager_unittest.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698