Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(96)

Side by Side Diff: components/view_manager/focus_controller_delegate.h

Issue 1344573002: Mandoline: Rename components/view_manager to components/mus (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@master
Patch Set: Rebased Created 5 years, 3 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch
OLDNEW
(Empty)
1 // Copyright 2015 The Chromium Authors. All rights reserved.
2 // Use of this source code is governed by a BSD-style license that can be
3 // found in the LICENSE file.
4
5 #ifndef COMPONENTS_VIEW_MANAGER_FOCUS_CONTROLLER_DELEGATE_H_
6 #define COMPONENTS_VIEW_MANAGER_FOCUS_CONTROLLER_DELEGATE_H_
7
8 namespace view_manager {
9
10 class ServerView;
11
12 class FocusControllerDelegate {
13 public:
14 virtual void OnFocusChanged(ServerView* old_focused_view,
15 ServerView* new_focused_view) = 0;
16
17 protected:
18 ~FocusControllerDelegate() {}
19 };
20
21 } // namespace view_manager
22
23 #endif // COMPONENTS_VIEW_MANAGER_FOCUS_CONTROLLER_DELEGATE_H_
OLDNEW
« no previous file with comments | « components/view_manager/focus_controller.cc ('k') | components/view_manager/focus_controller_unittest.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698