Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(146)

Side by Side Diff: components/view_manager/android_loader.h

Issue 1344573002: Mandoline: Rename components/view_manager to components/mus (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@master
Patch Set: Rebased Created 5 years, 3 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch
OLDNEW
(Empty)
1 // Copyright 2015 The Chromium Authors. All rights reserved.
2 // Use of this source code is governed by a BSD-style license that can be
3 // found in the LICENSE file.
4
5 #ifndef COMPONENTS_VIEW_MANAGER_ANDROID_LOADER_H_
6 #define COMPONENTS_VIEW_MANAGER_ANDROID_LOADER_H_
7
8 #include "mojo/shell/application_loader.h"
9
10 namespace mojo {
11 class ApplicationImpl;
12 }
13
14 namespace view_manager {
15
16 class AndroidLoader : public mojo::shell::ApplicationLoader {
17 public:
18 AndroidLoader();
19 ~AndroidLoader();
20
21 private:
22 // Overridden from mojo::shell::ApplicationLoader:
23 void Load(
24 const GURL& url,
25 mojo::InterfaceRequest<mojo::Application> application_request) override;
26
27 scoped_ptr<mojo::ApplicationImpl> app_;
28
29 DISALLOW_COPY_AND_ASSIGN(AndroidLoader);
30 };
31
32 } // namespace view_manager
33
34 #endif // COMPONENTS_VIEW_MANAGER_ANDROID_LOADER_H_
OLDNEW
« no previous file with comments | « components/view_manager/access_policy_delegate.h ('k') | components/view_manager/android_loader.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698