Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(646)

Unified Diff: src/gpu/GrPrimitiveProcessor.h

Issue 1297503007: Generating gl processor key is now recursive (Closed) Base URL: https://skia.googlesource.com/skia@cs3_numExclChildren
Patch Set: rebased Created 5 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « no previous file | src/gpu/GrPrimitiveProcessor.cpp » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/gpu/GrPrimitiveProcessor.h
diff --git a/src/gpu/GrPrimitiveProcessor.h b/src/gpu/GrPrimitiveProcessor.h
index 6d336048c85124f378b4db34381e237a948a7eb0..6c886aeb6393543b9a5aa56f4065ce8841ffeb56 100644
--- a/src/gpu/GrPrimitiveProcessor.h
+++ b/src/gpu/GrPrimitiveProcessor.h
@@ -220,13 +220,19 @@ public:
size_t getVertexStride() const { return fVertexStride; }
/**
- * Gets a transformKey from an array of coord transforms
+ * Computes a transformKey from an array of coord transforms. Will only look at the first
+ * <numCoords> transforms in the array.
+ *
+ * TODO: A better name for this function would be "compute" instead of "get".
*/
- uint32_t getTransformKey(const SkTArray<const GrCoordTransform*, true>&) const;
+ uint32_t getTransformKey(const SkTArray<const GrCoordTransform*, true>& coords,
+ int numCoords) const;
/**
* Sets a unique key on the GrProcessorKeyBuilder that is directly associated with this geometry
* processor's GL backend implementation.
+ *
+ * TODO: A better name for this function would be "compute" instead of "get".
*/
virtual void getGLProcessorKey(const GrBatchTracker& bt,
const GrGLSLCaps& caps,
« no previous file with comments | « no previous file | src/gpu/GrPrimitiveProcessor.cpp » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698