Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(4335)

Unified Diff: runtime/lib/timer_patch.dart

Issue 12793003: Rename Timer.repeating to Timer.periodic. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 7 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: runtime/lib/timer_patch.dart
diff --git a/runtime/lib/timer_patch.dart b/runtime/lib/timer_patch.dart
index fd3efbd8048e06647edbca83ecbe266e6e9a5b2d..2db2343720a1e6ad6e14c7f6b9ea351075bbd68d 100644
--- a/runtime/lib/timer_patch.dart
+++ b/runtime/lib/timer_patch.dart
@@ -12,8 +12,8 @@ patch class Timer {
return _TimerFactory._factory(milliseconds, (_) { callback(); }, false);
}
- /* patch */ factory Timer.repeating(Duration duration,
- void callback(Timer timer)) {
+ /* patch */ factory Timer.periodic(Duration duration,
+ void callback(Timer timer)) {
if (_TimerFactory._factory == null) {
throw new UnsupportedError("Timer interface not supported.");
}

Powered by Google App Engine
This is Rietveld 408576698