Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(55)

Unified Diff: utils/pub/log.dart

Issue 12610006: Renamed StreamSink to EventSink. Renamed signalError to addError. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Changed inheritance back! Now create StreamSink instead of EventSink where we create them. Created 7 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: utils/pub/log.dart
diff --git a/utils/pub/log.dart b/utils/pub/log.dart
index 5f1c578ad930e2f73b665daadf4e1c9dd3db1321..870a305671abf15d1690deecc0dab04222c82489 100644
--- a/utils/pub/log.dart
+++ b/utils/pub/log.dart
@@ -208,7 +208,7 @@ void _logToStderrWithLabel(Entry entry) {
_logToStream(stderrSink, entry, showLabel: true);
}
-void _logToStream(StreamSink<List<int>> sink, Entry entry, {bool showLabel}) {
+void _logToStream(EventSink<List<int>> sink, Entry entry, {bool showLabel}) {
bool firstLine = true;
for (var line in entry.lines) {
if (showLabel) {

Powered by Google App Engine
This is Rietveld 408576698