Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(271)

Unified Diff: lib/src/utils.dart

Issue 1253903004: add special case for min/max, fixes #281 (Closed) Base URL: git@github.com:dart-lang/dev_compiler.git@master
Patch Set: small tweak for clarity Created 5 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « lib/src/dart_sdk.dart ('k') | test/checker/checker_test.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: lib/src/utils.dart
diff --git a/lib/src/utils.dart b/lib/src/utils.dart
index 9511c2bd5941753d123c4a6c07725c41baa4837c..b561c596dbc8cfc1ea07e4cb75780440cea4ede0 100644
--- a/lib/src/utils.dart
+++ b/lib/src/utils.dart
@@ -452,3 +452,7 @@ String errorCodeName(ErrorCode errorCode) {
bool isInlineJS(Element e) => e is FunctionElement &&
e.library.source.uri.toString() == 'dart:_foreign_helper' &&
e.name == 'JS';
+
+bool isDartMathMinMax(Element e) => e is FunctionElement &&
+ e.library.source.uri.toString() == 'dart:math' &&
+ (e.name == 'min' || e.name == 'max');
« no previous file with comments | « lib/src/dart_sdk.dart ('k') | test/checker/checker_test.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698