Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(333)

Unified Diff: remoting/protocol/authenticator_test_base.h

Issue 12316083: Move HostKeyPair into protocol::KeyPair. (Closed) Base URL: http://git.chromium.org/chromium/src.git@master
Patch Set: Rename key_pair_ to local_key_pair_ Created 7 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: remoting/protocol/authenticator_test_base.h
diff --git a/remoting/protocol/authenticator_test_base.h b/remoting/protocol/authenticator_test_base.h
index fc4856c5ca5f8b0ccbc85a40e5c7867116cb3987..64d1c485b5b3396d829691d9b3c1658606431adf 100644
--- a/remoting/protocol/authenticator_test_base.h
+++ b/remoting/protocol/authenticator_test_base.h
@@ -7,20 +7,20 @@
#include <string>
+#include "base/memory/ref_counted.h"
#include "base/message_loop.h"
#include "net/base/net_errors.h"
#include "testing/gmock/include/gmock/gmock.h"
#include "testing/gtest/include/gtest/gtest.h"
-namespace crypto {
-class RSAPrivateKey;
-} // namespace crypto
-
namespace net {
class StreamSocket;
} // namespace net
namespace remoting {
+
+class RsaKeyPair;
+
namespace protocol {
class Authenticator;
@@ -51,7 +51,7 @@ class AuthenticatorTestBase : public testing::Test {
MessageLoop message_loop_;
- scoped_ptr<crypto::RSAPrivateKey> private_key_;
+ scoped_refptr<RsaKeyPair> key_pair_;
std::string host_cert_;
scoped_ptr<Authenticator> host_;
scoped_ptr<Authenticator> client_;

Powered by Google App Engine
This is Rietveld 408576698