|
|
Created:
6 years, 11 months ago by pgervais Modified:
6 years, 11 months ago CC:
chromium-reviews, Dirk Pranke, cmp-cc_chromium.org, M-A Ruel, iannucci+depot_tools_chromium.org, ilevy-cc_chromium.org Base URL:
https://chromium.googlesource.com/chromium/tools/depot_tools.git@master Visibility:
Public. |
DescriptionAdded --email to git_cl.py
Passing the email address used to connect to Rietveld on the command
line is useful for testing purposes, in particular with a test server.
BUG=331123
Committed: http://src.chromium.org/viewvc/chrome?view=rev&revision=244017
Patch Set 1 #
Total comments: 2
Messages
Total messages: 12 (0 generated)
See crbug.com/331123 for background info.
On 2013/12/30 23:07:09, pgervais wrote: > See crbug.com/331123 for background info. ping to robbie, in case he has forgotten about this CR :-)
https://chromiumcodereview.appspot.com/122583003/diff/1/git_cl.py File git_cl.py (right): https://chromiumcodereview.appspot.com/122583003/diff/1/git_cl.py#newcode1566 git_cl.py:1566: parser.add_option('--email', default=None, Hm... what about 'username'? Since git_cl already has --sent-mail, --email might be confusing. Though I guess it's --email in upload.py, which is ALSO confusing.... *sigh* lgtm
a last question, and you're done! (or not) https://chromiumcodereview.appspot.com/122583003/diff/1/git_cl.py File git_cl.py (right): https://chromiumcodereview.appspot.com/122583003/diff/1/git_cl.py#newcode1566 git_cl.py:1566: parser.add_option('--email', default=None, On 2014/01/09 22:46:42, iannucci wrote: > Hm... what about 'username'? Since git_cl already has --sent-mail, --email might > be confusing. > > Though I guess it's --email in upload.py, which is ALSO confusing.... *sigh* > Exactly :-) It's not too late, I can change the name of this option if you feel that --email is too confusing. --username seems fine.
lgtm
On 2014/01/09 22:50:55, pgervais wrote: > a last question, and you're done! (or not) > > https://chromiumcodereview.appspot.com/122583003/diff/1/git_cl.py > File git_cl.py (right): > > https://chromiumcodereview.appspot.com/122583003/diff/1/git_cl.py#newcode1566 > git_cl.py:1566: parser.add_option('--email', default=None, > On 2014/01/09 22:46:42, iannucci wrote: > > Hm... what about 'username'? Since git_cl already has --sent-mail, --email > might > > be confusing. > > > > Though I guess it's --email in upload.py, which is ALSO confusing.... *sigh* > > > Exactly :-) > > It's not too late, I can change the name of this option if you feel that --email > is too confusing. --username seems fine. Yeah, but I think it would be equally confusing to have '--username' turn into '--email' :/
Then I can add the --username option to upload.py :-) [and leave --email for backward compatibility] On Thu, Jan 9, 2014 at 2:53 PM, <iannucci@chromium.org> wrote: > On 2014/01/09 22:50:55, pgervais wrote: > >> a last question, and you're done! (or not) >> > > https://chromiumcodereview.appspot.com/122583003/diff/1/git_cl.py >> File git_cl.py (right): >> > > https://chromiumcodereview.appspot.com/122583003/diff/1/ >> git_cl.py#newcode1566 >> git_cl.py:1566: parser.add_option('--email', default=None, >> On 2014/01/09 22:46:42, iannucci wrote: >> > Hm... what about 'username'? Since git_cl already has --sent-mail, >> --email >> might >> > be confusing. >> > >> > Though I guess it's --email in upload.py, which is ALSO confusing.... >> *sigh* >> > >> Exactly :-) >> > > It's not too late, I can change the name of this option if you feel that >> > --email > >> is too confusing. --username seems fine. >> > > Yeah, but I think it would be equally confusing to have '--username' turn > into > '--email' :/ > > https://chromiumcodereview.appspot.com/122583003/ > To unsubscribe from this group and stop receiving emails from it, send an email to chromium-reviews+unsubscribe@chromium.org.
That would achieve levels of confusion previously thought impossible. On Thu, Jan 9, 2014 at 2:58 PM, Philippe Gervais <pgervais@chromium.org>wrote: > Then I can add the --username option to upload.py :-) [and leave --email > for backward compatibility] > > > On Thu, Jan 9, 2014 at 2:53 PM, <iannucci@chromium.org> wrote: > >> On 2014/01/09 22:50:55, pgervais wrote: >> >>> a last question, and you're done! (or not) >>> >> >> https://chromiumcodereview.appspot.com/122583003/diff/1/git_cl.py >>> File git_cl.py (right): >>> >> >> https://chromiumcodereview.appspot.com/122583003/diff/1/ >>> git_cl.py#newcode1566 >>> git_cl.py:1566: parser.add_option('--email', default=None, >>> On 2014/01/09 22:46:42, iannucci wrote: >>> > Hm... what about 'username'? Since git_cl already has --sent-mail, >>> --email >>> might >>> > be confusing. >>> > >>> > Though I guess it's --email in upload.py, which is ALSO confusing.... >>> *sigh* >>> > >>> Exactly :-) >>> >> >> It's not too late, I can change the name of this option if you feel that >>> >> --email >> >>> is too confusing. --username seems fine. >>> >> >> Yeah, but I think it would be equally confusing to have '--username' turn >> into >> '--email' :/ >> >> https://chromiumcodereview.appspot.com/122583003/ >> > > To unsubscribe from this group and stop receiving emails from it, send an email to chromium-reviews+unsubscribe@chromium.org.
On 2014/01/09 23:04:52, smut wrote: > That would achieve levels of confusion previously thought impossible. > :D Well... upload.py is the domain of rietveld. I wouldn't recommend changing it. I plan to switch the primary authentication scheme to be oauth2 with the new upload.py anyway... I would just leave it as '--email' for now. > On Thu, Jan 9, 2014 at 2:58 PM, Philippe Gervais <pgervais@chromium.org>wrote: > > > Then I can add the --username option to upload.py :-) [and leave --email > > for backward compatibility] > > > > > > On Thu, Jan 9, 2014 at 2:53 PM, <mailto:iannucci@chromium.org> wrote: > > > >> On 2014/01/09 22:50:55, pgervais wrote: > >> > >>> a last question, and you're done! (or not) > >>> > >> > >> https://chromiumcodereview.appspot.com/122583003/diff/1/git_cl.py > >>> File git_cl.py (right): > >>> > >> > >> https://chromiumcodereview.appspot.com/122583003/diff/1/ > >>> git_cl.py#newcode1566 > >>> git_cl.py:1566: parser.add_option('--email', default=None, > >>> On 2014/01/09 22:46:42, iannucci wrote: > >>> > Hm... what about 'username'? Since git_cl already has --sent-mail, > >>> --email > >>> might > >>> > be confusing. > >>> > > >>> > Though I guess it's --email in upload.py, which is ALSO confusing.... > >>> *sigh* > >>> > > >>> Exactly :-) > >>> > >> > >> It's not too late, I can change the name of this option if you feel that > >>> > >> --email > >> > >>> is too confusing. --username seems fine. > >>> > >> > >> Yeah, but I think it would be equally confusing to have '--username' turn > >> into > >> '--email' :/ > >> > >> https://chromiumcodereview.appspot.com/122583003/ > >> > > > > > > To unsubscribe from this group and stop receiving emails from it, send an email > to mailto:chromium-reviews+unsubscribe@chromium.org.
On 2014/01/09 23:10:00, iannucci wrote: > On 2014/01/09 23:04:52, smut wrote: > > That would achieve levels of confusion previously thought impossible. > > > > :D :-D > Well... upload.py is the domain of rietveld. I wouldn't recommend changing it. > > I plan to switch the primary authentication scheme to be oauth2 with the new > upload.py anyway... > > I would just leave it as '--email' for now. > ok, I'm committing then. Thanks for your input.
CQ is trying da patch. Follow status at https://chromium-status.appspot.com/cq/pgervais@chromium.org/122583003/1
Message was sent while issue was closed.
Change committed as 244017 |