Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(669)

Unified Diff: utils/pub/git_source.dart

Issue 12092080: Validate packages against their SDK constraints. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Clean up a bit. Created 7 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: utils/pub/git_source.dart
diff --git a/utils/pub/git_source.dart b/utils/pub/git_source.dart
index 477cc17a7e9bd17ed250476516aed5e259e423f4..2b46706c8a8b168187fa463610ade1b2dddad1dd 100644
--- a/utils/pub/git_source.dart
+++ b/utils/pub/git_source.dart
@@ -60,6 +60,8 @@ class GitSource extends Source {
});
}
+ Future<String> systemCacheDirectory(PackageId id) => _revisionCachePath(id);
nweiz 2013/01/31 22:38:53 Why not just rename "_revisionCachePath" to "syste
Bob Nystrom 2013/02/01 16:53:29 I kept it because I like that it helps clarify the
nweiz 2013/02/01 22:24:54 I don't like having two differently-named function
Bob Nystrom 2013/02/02 00:02:31 Done.
+
/// Ensures [description] is a Git URL.
void validateDescription(description, {bool fromLockFile: false}) {
// A single string is assumed to be a Git URL.

Powered by Google App Engine
This is Rietveld 408576698