Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(592)

Unified Diff: utils/pub/utils.dart

Issue 12086062: Rename mappedBy to map. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 7 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: utils/pub/utils.dart
diff --git a/utils/pub/utils.dart b/utils/pub/utils.dart
index c807ea82b9cee018bf576112d9a7ad2ed64a85da..0db69215104666c1bdd0a2cac9240adccb5b21e4 100644
--- a/utils/pub/utils.dart
+++ b/utils/pub/utils.dart
@@ -239,7 +239,7 @@ String mapToQuery(Map<String, String> map) {
value = (value == null || value.isEmpty) ? null : encodeUriComponent(value);
pairs.add([key, value]);
});
- return Strings.join(pairs.mappedBy((pair) {
+ return Strings.join(pairs.map((pair) {
if (pair[1] == null) return pair[0];
return "${pair[0]}=${pair[1]}";
}), "&");

Powered by Google App Engine
This is Rietveld 408576698