Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(119)

Unified Diff: utils/pub/hosted_source.dart

Issue 12086062: Rename mappedBy to map. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 7 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: utils/pub/hosted_source.dart
diff --git a/utils/pub/hosted_source.dart b/utils/pub/hosted_source.dart
index 27901362a6ddd420a3a83b5b9c39f593397e02d7..2d811ca366d473e59f675318e16b695896bc639b 100644
--- a/utils/pub/hosted_source.dart
+++ b/utils/pub/hosted_source.dart
@@ -39,7 +39,7 @@ class HostedSource extends Source {
return httpClient.read(fullUrl).then((body) {
var doc = json.parse(body);
return doc['versions']
- .mappedBy((version) => new Version.parse(version))
+ .map((version) => new Version.parse(version))
.toList();
}).catchError((ex) {
_throwFriendlyError(ex, parsed.first, parsed.last);

Powered by Google App Engine
This is Rietveld 408576698