Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(177)

Unified Diff: sdk/lib/_internal/compiler/implementation/lib/constant_map.dart

Issue 12086062: Rename mappedBy to map. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 7 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: sdk/lib/_internal/compiler/implementation/lib/constant_map.dart
diff --git a/sdk/lib/_internal/compiler/implementation/lib/constant_map.dart b/sdk/lib/_internal/compiler/implementation/lib/constant_map.dart
index 625e0ed7cf8e3e744387518d9195d406952954d8..6b9a6c2cab48f4106fa5a18ea8a8e586880f8c49 100644
--- a/sdk/lib/_internal/compiler/implementation/lib/constant_map.dart
+++ b/sdk/lib/_internal/compiler/implementation/lib/constant_map.dart
@@ -36,7 +36,7 @@ class ConstantMap<V> implements Map<String, V> {
Iterable<V> get values {
// TODO(floitsch): don't wrap the map twice.
floitsch 2013/01/30 14:48:44 Now that map returns an Iterable you can just retu
Lasse Reichstein Nielsen 2013/01/31 11:33:49 Done.
- return keys.mappedBy((String key) => this[key]);
+ return keys.map((String key) => this[key]);
}
bool get isEmpty => length == 0;

Powered by Google App Engine
This is Rietveld 408576698