Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1154)

Unified Diff: sky/sdk/lib/widgets/popup_menu.dart

Issue 1190793002: Rename UINode to Widget. (Closed) Base URL: https://github.com/domokit/mojo.git@master
Patch Set: Created 5 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « sky/sdk/lib/widgets/navigator.dart ('k') | sky/sdk/lib/widgets/popup_menu_item.dart » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: sky/sdk/lib/widgets/popup_menu.dart
diff --git a/sky/sdk/lib/widgets/popup_menu.dart b/sky/sdk/lib/widgets/popup_menu.dart
index 27a22bc7988cac9513f553c62abe24de3305294b..6ac1be4b9d55ee4b6f0eda6952707c82a1b5d0ef 100644
--- a/sky/sdk/lib/widgets/popup_menu.dart
+++ b/sky/sdk/lib/widgets/popup_menu.dart
@@ -67,7 +67,7 @@ class PopupMenu extends AnimatedComponent {
}
PopupMenuController controller;
- List<UINode> items;
+ List<Widget> items;
int level;
void syncFields(PopupMenu source) {
@@ -90,9 +90,9 @@ class PopupMenu extends AnimatedComponent {
return math.max(0.0, math.min(1.0, (_position - start) / duration));
}
- UINode build() {
+ Widget build() {
int i = 0;
- List<UINode> children = new List.from(items.map((UINode item) {
+ List<Widget> children = new List.from(items.map((Widget item) {
double opacity = _opacityFor(i);
return new PopupMenuItem(key: '${key}-${item.key}',
child: item,
« no previous file with comments | « sky/sdk/lib/widgets/navigator.dart ('k') | sky/sdk/lib/widgets/popup_menu_item.dart » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698