Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(197)

Unified Diff: Source/core/animation/Animation.cpp

Issue 1160253006: Rename LifecycleObserver<T>::dispose() as clearContext() (Closed) Base URL: svn://svn.chromium.org/blink/trunk
Patch Set: rename as clearContext() Created 5 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « no previous file | Source/core/inspector/AsyncCallTracker.cpp » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: Source/core/animation/Animation.cpp
diff --git a/Source/core/animation/Animation.cpp b/Source/core/animation/Animation.cpp
index 5103120d88fef661182dd039d0726bcd241fb484..cc4d63eedea829401dfefc123460e3f3c6c09b2c 100644
--- a/Source/core/animation/Animation.cpp
+++ b/Source/core/animation/Animation.cpp
@@ -120,8 +120,8 @@ Animation::~Animation()
#if !ENABLE(OILPAN)
void Animation::detachFromTimeline()
{
- dispose();
m_timeline = nullptr;
+ ActiveDOMObject::clearContext();
}
#endif
« no previous file with comments | « no previous file | Source/core/inspector/AsyncCallTracker.cpp » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698