Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(548)

Unified Diff: include/v8.h

Issue 11552033: This patch is the propagation version of https://codereview.chromium.org/10824032 patch (Closed) Base URL: http://v8.googlecode.com/svn/branches/bleeding_edge/
Patch Set: Created 8 years ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « no previous file | src/assembler.h » ('j') | src/assembler.h » ('J')
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: include/v8.h
===================================================================
--- include/v8.h (revision 13212)
+++ include/v8.h (working copy)
@@ -3021,7 +3021,6 @@
typedef void (*FunctionEntryHook)(uintptr_t function,
uintptr_t return_addr_location);
-
danno 2012/12/20 16:27:20 nit: Please don't remove whitespace not in accorda
/**
* A JIT code event is issued each time code is added, moved or removed.
*
@@ -3031,7 +3030,10 @@
enum EventType {
CODE_ADDED,
CODE_MOVED,
- CODE_REMOVED
+ CODE_REMOVED,
+ CODE_ADD_LINE_POS_INFO,
+ CODE_START_LINE_INFO_RECORDING,
+ CODE_END_LINE_INFO_RECORDING
};
// Type of event.
@@ -3040,6 +3042,9 @@
void* code_start;
// Size of the instructions.
size_t code_len;
+ // It can be Script info for CODE_ADDDED event or line_info_struct
danno 2012/12/20 16:27:20 How about removing the "It can be", and only two D
+ // for CODE_ADD_LINE_POS_INFO and CODE_END_LINE_INFO_RECORDING event
+ void* userdata;
danno 2012/12/20 16:27:20 user_data is probably better. Also, why not have t
union {
// Only valid for CODE_ADDED.
@@ -3050,6 +3055,17 @@
// Number of chars in str.
size_t len;
} name;
+
+ // Only valid for CODE_ADD_LINE_INFO
danno 2012/12/20 16:27:20 CODE_ADD_LINE_POS_INFO
+ struct {
+ // PC offset
+ unsigned offset;
danno 2012/12/20 16:27:20 Why use unsigned rather than a size_t? This seems
+ // Code postion
+ unsigned pos;
danno 2012/12/20 16:27:20 Same here
+ // Whether this position is statement
danno 2012/12/20 16:27:20 How about you clarify what it is if it isn't a sta
+ bool is_statement;
+ } line_info;
+
// New location of instructions. Only valid for CODE_MOVED.
void* new_code_start;
};
« no previous file with comments | « no previous file | src/assembler.h » ('j') | src/assembler.h » ('J')

Powered by Google App Engine
This is Rietveld 408576698