Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(200)

Issue 11299020: Make creation of list literal more resilient to changes in the underlying (Closed)

Created:
8 years, 1 month ago by regis
Modified:
8 years, 1 month ago
Reviewers:
siva
CC:
reviews_dartlang.org
Visibility:
Public.

Description

Make creation of list literal more resilient to changes in the underlying dart implementation of List in the core library. Do the same for map literal creation. Committed: https://code.google.com/p/dart/source/detail?r=14997

Patch Set 1 #

Patch Set 2 : #

Total comments: 5
Unified diffs Side-by-side diffs Delta from patch set Stats (+111 lines, -68 lines) Patch
M runtime/vm/ast.h View 1 chunk +3 lines, -0 lines 0 comments Download
M runtime/vm/code_generator.cc View 1 chunk +1 line, -1 line 0 comments Download
M runtime/vm/dart_api_impl.cc View 1 chunk +5 lines, -3 lines 0 comments Download
M runtime/vm/flow_graph_builder.cc View 1 chunk +1 line, -1 line 0 comments Download
M runtime/vm/flow_graph_compiler_ia32.cc View 1 chunk +1 line, -1 line 2 comments Download
M runtime/vm/flow_graph_compiler_x64.cc View 1 chunk +1 line, -1 line 1 comment Download
M runtime/vm/object.h View 4 chunks +5 lines, -6 lines 0 comments Download
M runtime/vm/object.cc View 5 chunks +18 lines, -15 lines 0 comments Download
M runtime/vm/object_store.h View 3 chunks +7 lines, -5 lines 0 comments Download
M runtime/vm/object_store.cc View 1 chunk +2 lines, -1 line 0 comments Download
M runtime/vm/parser.cc View 1 8 chunks +62 lines, -29 lines 2 comments Download
M runtime/vm/snapshot.cc View 3 chunks +4 lines, -4 lines 0 comments Download
M runtime/vm/snapshot_ids.h View 1 chunk +1 line, -1 line 0 comments Download

Messages

Total messages: 4 (0 generated)
regis
8 years, 1 month ago (2012-11-16 00:02:35 UTC) #1
regis
TBR Submitted TBR, since I am out the office tomorrow and I do not want ...
8 years, 1 month ago (2012-11-16 01:33:40 UTC) #2
siva
lgtm https://codereview.chromium.org/11299020/diff/5002/runtime/vm/flow_graph_compiler_ia32.cc File runtime/vm/flow_graph_compiler_ia32.cc (right): https://codereview.chromium.org/11299020/diff/5002/runtime/vm/flow_graph_compiler_ia32.cc#newcode161 runtime/vm/flow_graph_compiler_ia32.cc:161: if (type_class.raw() == Isolate::Current()->object_store()->list_class()) { why not have ...
8 years, 1 month ago (2012-11-16 02:24:50 UTC) #3
regis
8 years, 1 month ago (2012-11-20 19:37:33 UTC) #4
Thanks!

https://codereview.chromium.org/11418098 on its way.

https://codereview.chromium.org/11299020/diff/5002/runtime/vm/flow_graph_comp...
File runtime/vm/flow_graph_compiler_ia32.cc (right):

https://codereview.chromium.org/11299020/diff/5002/runtime/vm/flow_graph_comp...
runtime/vm/flow_graph_compiler_ia32.cc:161: if (type_class.raw() ==
Isolate::Current()->object_store()->list_class()) {
On 2012/11/16 02:24:50, siva wrote:
> why not have a ListClass() helper in Class it would
> make the code more readable.

Done (in a follow-up cl).

https://codereview.chromium.org/11299020/diff/5002/runtime/vm/flow_graph_comp...
File runtime/vm/flow_graph_compiler_x64.cc (right):

https://codereview.chromium.org/11299020/diff/5002/runtime/vm/flow_graph_comp...
runtime/vm/flow_graph_compiler_x64.cc:161: if (type_class.raw() ==
Isolate::Current()->object_store()->list_class()) {
Done here too.

https://codereview.chromium.org/11299020/diff/5002/runtime/vm/parser.cc
File runtime/vm/parser.cc (right):

https://codereview.chromium.org/11299020/diff/5002/runtime/vm/parser.cc#newco...
runtime/vm/parser.cc:8711: Type::Handle(Type::ArrayType()).type_class());
On 2012/11/16 02:24:50, siva wrote:
> Why not just do
> const Class& array_class = Class::Handle(
>   Isolate::Current()->object_store()->array_class());
> 
> or if you had the helper method it would be
> const Class& array_class = Class::Handle(Class::ListClass());

The ListClass helper would be the wrong one here, since we want the class of
Array, not of List. I changed the code according to your first suggestion (in a
follow-up cl).

Powered by Google App Engine
This is Rietveld 408576698