Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(273)

Side by Side Diff: Source/core/animation/AnimationTimingProperties.idl

Issue 1113173003: Web Animations: Update naming to reflect spec changes (Closed) Base URL: svn://svn.chromium.org/blink/trunk
Patch Set: No, really. Created 5 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch | Annotate | Revision Log
OLDNEW
(Empty)
1 // Copyright 2015 The Chromium Authors. All rights reserved.
2 // Use of this source code is governed by a BSD-style license that can be
3 // found in the LICENSE file.
4
5 // https://w3c.github.io/web-animations/#the-animationeffecttimingproperties-dic tionary
6
7 // TODO(dstockwell): Rename this to AnimationEffectTimingProperties.
8 dictionary AnimationTimingProperties {
9 double delay = 0;
10 double endDelay = 0;
11 // TODO(dstockwell): The fill type should be FillMode.
12 DOMString fill = "auto";
13 double iterationStart = 0.0;
14 unrestricted double iterations = 1.0;
15 (unrestricted double or DOMString) duration = "auto";
16 // TODO(dstockwell): There is no playbackRate member in the spec.
17 double playbackRate = 1.0;
18 // TODO(dstockwell): The direction type should be PlaybackDirection.
19 DOMString direction = "normal";
20 DOMString easing = "linear";
21 };
OLDNEW
« no previous file with comments | « Source/core/animation/AnimationTimelineTest.cpp ('k') | Source/core/animation/CompositorAnimations.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698