Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(262)

Unified Diff: lib/compiler/implementation/diagnostic_listener.dart

Issue 11090016: Change core lib, dart2js, and more for new optional parameters syntax (Closed) Base URL: http://dart.googlecode.com/svn/branches/bleeding_edge/dart/
Patch Set: Created 8 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: lib/compiler/implementation/diagnostic_listener.dart
===================================================================
--- lib/compiler/implementation/diagnostic_listener.dart (revision 13683)
+++ lib/compiler/implementation/diagnostic_listener.dart (working copy)
@@ -4,15 +4,15 @@
abstract class DiagnosticListener {
// TODO(karlklose): replace cancel with better error reporting mechanism.
- void cancel([String reason, node, token, instruction, element]);
+ void cancel(String reason, {node, token, instruction, element});
// TODO(karlklose): rename log to something like reportInfo.
void log(message);
// TODO(karlklose): add reportWarning and reportError to this interface.
void internalErrorOnElement(Element element, String message);
void internalError(String message,
- [Node node, Token token, HInstruction instruction,
- Element element]);
+ {Node node, Token token, HInstruction instruction,
+ Element element});
SourceSpan spanFromNode(Node node, [Uri uri]);

Powered by Google App Engine
This is Rietveld 408576698