Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(202)

Unified Diff: src/generator.js

Issue 1093183006: [es6] Map/Set size getter should have "get size" name (Closed) Base URL: https://chromium.googlesource.com/v8/v8.git@master
Patch Set: Use IS_UNDEFINED instead Created 5 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/collection-iterator.js ('k') | src/i18n.js » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/generator.js
diff --git a/src/generator.js b/src/generator.js
index e33cd29555352827943ddfd05203dbc0023f3994..2b0bcbd4b36b36376eda3966256604ecb339b0c1 100644
--- a/src/generator.js
+++ b/src/generator.js
@@ -95,7 +95,7 @@ InstallFunctions(GeneratorObjectPrototype,
["next", GeneratorObjectNext,
"throw", GeneratorObjectThrow]);
-%FunctionSetName(GeneratorObjectIterator, '[Symbol.iterator]');
+SetFunctionName(GeneratorObjectIterator, symbolIterator);
%AddNamedProperty(GeneratorObjectPrototype, symbolIterator,
GeneratorObjectIterator, DONT_ENUM | DONT_DELETE | READ_ONLY);
%AddNamedProperty(GeneratorObjectPrototype, "constructor",
« no previous file with comments | « src/collection-iterator.js ('k') | src/i18n.js » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698