Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(584)

Side by Side Diff: components/undo/BUILD.gn

Issue 1090993003: Move undo files into //components/undo (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@utils
Patch Set: Rebase Created 5 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch
« no previous file with comments | « components/undo.gypi ('k') | components/undo/DEPS » ('j') | no next file with comments »
Toggle Intra-line Diffs ('i') | Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
OLDNEW
1 # Copyright 2015 The Chromium Authors. All rights reserved. 1 # Copyright 2015 The Chromium Authors. All rights reserved.
2 # Use of this source code is governed by a BSD-style license that can be 2 # Use of this source code is governed by a BSD-style license that can be
3 # found in the LICENSE file. 3 # found in the LICENSE file.
4 4
5 source_set("managed") { 5 static_library("undo") {
6 sources = [ 6 sources = [
7 "managed_bookmarks_tracker.cc", 7 "bookmark_renumber_observer.h",
8 "managed_bookmarks_tracker.h", 8 "bookmark_undo_service.cc",
9 "bookmark_undo_service.h",
10 "undo_manager.cc",
11 "undo_manager.h",
12 "undo_manager_observer.h",
13 "undo_operation.h",
9 ] 14 ]
10 15
11 deps = [ 16 deps = [
17 "//base",
12 "//components/bookmarks/browser", 18 "//components/bookmarks/browser",
19 "//components/keyed_service/core",
13 "//components/strings", 20 "//components/strings",
21 "//ui/base",
14 ] 22 ]
15 } 23 }
16 24
17 source_set("unit_tests") { 25 source_set("unit_tests") {
18 testonly = true 26 testonly = true
19 sources = [ 27 sources = [
20 "managed_bookmarks_tracker_unittest.cc", 28 "bookmark_undo_service_test.cc",
29 "undo_manager_test.cc",
21 ] 30 ]
22 31
23 configs += [ "//build/config/compiler:no_size_t_to_int_warning" ]
24
25 deps = [ 32 deps = [
26 ":managed",
27 "//components/bookmarks/test", 33 "//components/bookmarks/test",
28 "//components/strings", 34 "//components/undo",
droger 2015/04/17 09:06:21 Should it be ":undo" instead? I don't know if this
sdefresne 2015/04/17 13:52:00 There is no need, as //a/b is the same as //a/b:b.
tfarina 2015/04/17 20:53:15 I think that is not Roger was suggesting. What I
29 "//testing/gmock",
30 "//testing/gtest", 35 "//testing/gtest",
31 ] 36 ]
32 } 37 }
OLDNEW
« no previous file with comments | « components/undo.gypi ('k') | components/undo/DEPS » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698