Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(265)

Unified Diff: content/renderer/render_frame_impl.h

Issue 107183002: Move more of the plugin code in the renderer to use RenderFrame instead of RenderView. (Closed) Base URL: svn://chrome-svn/chrome/trunk/src/
Patch Set: Created 7 years ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: content/renderer/render_frame_impl.h
===================================================================
--- content/renderer/render_frame_impl.h (revision 238847)
+++ content/renderer/render_frame_impl.h (working copy)
@@ -160,6 +160,7 @@
virtual bool OnMessageReceived(const IPC::Message& msg) OVERRIDE;
// RenderFrame implementation:
+ virtual int GetRoutingID() OVERRIDE;
nasko 2013/12/05 22:43:45 Does it make sense to have both routing_id() and G
jam 2013/12/05 23:14:07 yep only one needed, removed routing_id()
virtual blink::WebPlugin* CreatePlugin(
blink::WebFrame* frame,
const WebPluginInfo& info,

Powered by Google App Engine
This is Rietveld 408576698