Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1451)

Unified Diff: src/compiler/node.cc

Issue 1032553006: [turbofan] Rename Node::RemoveAllInputs() to Node::NullAllInputs(). (Closed) Base URL: https://chromium.googlesource.com/v8/v8.git@master
Patch Set: Created 5 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/compiler/node.h ('k') | src/compiler/simplified-lowering.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/compiler/node.cc
diff --git a/src/compiler/node.cc b/src/compiler/node.cc
index 68eb73abd4c52bc9313a3a39cb5365466514dcab..1a9c326f20be0f37fd5aa36ba049f5bf8133cc51 100644
--- a/src/compiler/node.cc
+++ b/src/compiler/node.cc
@@ -40,7 +40,7 @@ Node* Node::New(Zone* zone, NodeId id, const Operator* op, int input_count,
void Node::Kill() {
DCHECK_NOT_NULL(op());
- RemoveAllInputs();
+ NullAllInputs();
DCHECK(uses().empty());
}
@@ -89,7 +89,7 @@ void Node::RemoveInput(int index) {
}
-void Node::RemoveAllInputs() {
+void Node::NullAllInputs() {
for (Edge edge : input_edges()) edge.UpdateTo(nullptr);
}
« no previous file with comments | « src/compiler/node.h ('k') | src/compiler/simplified-lowering.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698