Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(129)

Unified Diff: src/compiler/control-flow-optimizer.cc

Issue 1032553006: [turbofan] Rename Node::RemoveAllInputs() to Node::NullAllInputs(). (Closed) Base URL: https://chromium.googlesource.com/v8/v8.git@master
Patch Set: Created 5 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « no previous file | src/compiler/js-inlining.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/compiler/control-flow-optimizer.cc
diff --git a/src/compiler/control-flow-optimizer.cc b/src/compiler/control-flow-optimizer.cc
index b3a1a8bf58e403b76671d42571a79f35c23d50fb..f074f72602af2b1995013c25bbff7c0073c11e64 100644
--- a/src/compiler/control-flow-optimizer.cc
+++ b/src/compiler/control-flow-optimizer.cc
@@ -242,11 +242,11 @@ bool ControlFlowOptimizer::TryBuildSwitch(Node* node) {
DCHECK_NE(value, value1);
if (branch != node) {
- branch->RemoveAllInputs();
+ branch->NullAllInputs();
if_true->ReplaceInput(0, node);
}
if_true->set_op(common()->IfValue(value));
- if_false->RemoveAllInputs();
+ if_false->NullAllInputs();
Enqueue(if_true);
branch = branch1;
@@ -271,7 +271,7 @@ bool ControlFlowOptimizer::TryBuildSwitch(Node* node) {
if_false->set_op(common()->IfDefault());
if_false->ReplaceInput(0, node);
Enqueue(if_false);
- branch->RemoveAllInputs();
+ branch->NullAllInputs();
return true;
}
« no previous file with comments | « no previous file | src/compiler/js-inlining.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698