Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(41)

Unified Diff: public/platform/Platform.h

Issue 1029423004: Cache Storage: Add Platform API to retrieve CacheStorage for origin (Closed) Base URL: svn://svn.chromium.org/blink/trunk
Patch Set: Created 5 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: public/platform/Platform.h
diff --git a/public/platform/Platform.h b/public/platform/Platform.h
index 6f50d496c3e41f01c650a76c141327faa9991f22..f9cf64a37e36676fd3826e0fc7472c3419e3853c 100644
--- a/public/platform/Platform.h
+++ b/public/platform/Platform.h
@@ -73,7 +73,6 @@ class WebCookieJar;
class WebCrypto;
class WebDatabaseObserver;
class WebDiscardableMemory;
-class WebPlatformEventListener;
class WebFallbackThemeEngine;
class WebFileSystem;
class WebFileUtilities;
@@ -91,6 +90,7 @@ class WebMimeRegistry;
class WebNavigatorConnectProvider;
class WebNotificationManager;
class WebPermissionClient;
+class WebPlatformEventListener;
class WebPluginListBuilder;
class WebPrescientNetworking;
class WebPublicSuffixList;
@@ -99,8 +99,9 @@ class WebRTCPeerConnectionHandler;
class WebRTCPeerConnectionHandlerClient;
class WebSandboxSupport;
class WebScheduler;
-class WebSecurityOrigin;
class WebScrollbarBehavior;
+class WebSecurityOrigin;
+class WebServiceWorkerCacheStorage;
class WebSocketHandle;
class WebSpeechSynthesizer;
class WebSpeechSynthesizerClient;
@@ -219,6 +220,11 @@ public:
virtual WebIDBFactory* idbFactory() { return 0; }
+ // Cache Storage ----------------------------------------------------------
+
+ // The caller is responsible for deleting the returned object.
+ virtual WebServiceWorkerCacheStorage* cacheStorage(const WebString& identifier) { return nullptr; }
michaeln 2015/03/25 00:12:35 Maybe 'originIdentifier' for clarity. Also, should
kinuko 2015/03/25 03:57:23 I think nullptr is fine/preferred in new code.
jsbell 2015/03/25 16:25:52 originIdentifier - Done. I left it as nullptr, tho
+
// Gamepad -------------------------------------------------------------
virtual void sampleGamepads(WebGamepads& into) { into.length = 0; }

Powered by Google App Engine
This is Rietveld 408576698