Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(195)

Issue 11833025: Fix for issue 7757 (Closed)

Created:
7 years, 11 months ago by siva
Modified:
7 years, 11 months ago
Reviewers:
srdjan
CC:
reviews_dartlang.org
Visibility:
Public.

Description

Fix for issue 7757 - Iterate and collect all the inlined functions in an optimized dart frame into the stack frame when throwing an exception. - Added a OptimizedDartFrameIterator class which iterates over all the inlined functions of a single optimized dart frame. Committed: https://code.google.com/p/dart/source/detail?r=17000

Patch Set 1 #

Patch Set 2 : #

Patch Set 3 : #

Total comments: 12

Patch Set 4 : #

Unified diffs Side-by-side diffs Delta from patch set Stats (+166 lines, -51 lines) Patch
M runtime/tests/vm/vm.status View 1 2 3 1 chunk +2 lines, -4 lines 0 comments Download
M runtime/vm/code_generator.cc View 1 2 3 5 chunks +17 lines, -42 lines 0 comments Download
M runtime/vm/deopt_instructions.h View 1 2 3 1 chunk +6 lines, -0 lines 0 comments Download
M runtime/vm/deopt_instructions.cc View 1 2 3 2 chunks +23 lines, -0 lines 0 comments Download
M runtime/vm/exceptions.cc View 1 2 3 1 chunk +24 lines, -5 lines 0 comments Download
M runtime/vm/object.h View 1 2 3 1 chunk +2 lines, -0 lines 0 comments Download
M runtime/vm/object.cc View 1 2 3 1 chunk +24 lines, -0 lines 0 comments Download
M runtime/vm/stack_frame.h View 1 2 3 1 chunk +19 lines, -0 lines 0 comments Download
M runtime/vm/stack_frame.cc View 1 2 3 2 chunks +49 lines, -0 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
siva
7 years, 11 months ago (2013-01-10 02:16:48 UTC) #1
srdjan
LGTM https://chromiumcodereview.appspot.com/11833025/diff/20/runtime/vm/deopt_instructions.cc File runtime/vm/deopt_instructions.cc (right): https://chromiumcodereview.appspot.com/11833025/diff/20/runtime/vm/deopt_instructions.cc#newcode573 runtime/vm/deopt_instructions.cc:573: uword DeoptInstr::GetReturnAddress(intptr_t deopt_instr, You could remove argument deopt_instr. ...
7 years, 11 months ago (2013-01-10 21:53:57 UTC) #2
siva
7 years, 11 months ago (2013-01-12 00:20:54 UTC) #3
https://chromiumcodereview.appspot.com/11833025/diff/20/runtime/vm/deopt_inst...
File runtime/vm/deopt_instructions.cc (right):

https://chromiumcodereview.appspot.com/11833025/diff/20/runtime/vm/deopt_inst...
runtime/vm/deopt_instructions.cc:573: uword
DeoptInstr::GetReturnAddress(intptr_t deopt_instr,
Done.

I also renamed the function to GetRetAfterAddress as discussed offline.


On 2013/01/10 21:53:57, srdjan wrote:
> You could remove argument deopt_instr.

https://chromiumcodereview.appspot.com/11833025/diff/20/runtime/vm/deopt_inst...
File runtime/vm/deopt_instructions.h (right):

https://chromiumcodereview.appspot.com/11833025/diff/20/runtime/vm/deopt_inst...
runtime/vm/deopt_instructions.h:129: Function* func);
On 2013/01/10 21:53:57, srdjan wrote:
> Please add comment about the function's result & operation.

Done.

https://chromiumcodereview.appspot.com/11833025/diff/20/runtime/vm/exceptions.cc
File runtime/vm/exceptions.cc (right):

https://chromiumcodereview.appspot.com/11833025/diff/20/runtime/vm/exceptions...
runtime/vm/exceptions.cc:55: }
On 2013/01/10 21:53:57, srdjan wrote:
> ASSERT(pc != 0);

Done.

https://chromiumcodereview.appspot.com/11833025/diff/20/runtime/vm/stack_fram...
File runtime/vm/stack_frame.cc (right):

https://chromiumcodereview.appspot.com/11833025/diff/20/runtime/vm/stack_fram...
runtime/vm/stack_frame.cc:294: : index_(-1),
On 2013/01/10 21:53:57, srdjan wrote:
> set to 0

Done.

https://chromiumcodereview.appspot.com/11833025/diff/20/runtime/vm/stack_fram...
runtime/vm/stack_frame.cc:306: index_ = 0;
On 2013/01/10 21:53:57, srdjan wrote:
> remove

Done.

https://chromiumcodereview.appspot.com/11833025/diff/20/runtime/vm/stack_frame.h
File runtime/vm/stack_frame.h (right):

https://chromiumcodereview.appspot.com/11833025/diff/20/runtime/vm/stack_fram...
runtime/vm/stack_frame.h:232: class OptimizedDartFrameIterator : public
ValueObject {
I renamed it to InlinedFunctionsInDartFrameIterator

On 2013/01/10 21:53:57, srdjan wrote:
> InlinedFunctionsDartFrameIterator instead?

Powered by Google App Engine
This is Rietveld 408576698