Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(376)

Issue 11040062: Renamed Zone->StackZone, BaseZone->Zone, in preparation for changing isolate->get_zone() to return … (Closed)

Created:
8 years, 2 months ago by Tom Ball
Modified:
8 years, 2 months ago
Reviewers:
siva
CC:
reviews_dartlang.org
Visibility:
Public.

Description

Renamed Zone->StackZone, BaseZone->Zone, in preparation for changing isolate->get_zone() to return what was called the BaseZone instead of its wrapper. The GetBaseZone() methods were not renamed, to help the next CL. BUG= Committed: https://code.google.com/p/dart/source/detail?r=13314

Patch Set 1 #

Total comments: 8

Patch Set 2 : code review changes #

Unified diffs Side-by-side diffs Delta from patch set Stats (+107 lines, -106 lines) Patch
M runtime/lib/isolate.cc View 4 chunks +4 lines, -4 lines 0 comments Download
M runtime/lib/regexp_jsc.cc View 2 chunks +2 lines, -2 lines 0 comments Download
M runtime/lib/string.cc View 1 chunk +1 line, -1 line 0 comments Download
M runtime/vm/assembler.cc View 1 chunk +1 line, -1 line 0 comments Download
M runtime/vm/base_isolate.h View 3 chunks +4 lines, -4 lines 0 comments Download
M runtime/vm/benchmark_test.h View 1 chunk +1 line, -1 line 0 comments Download
M runtime/vm/bigint_operations_test.cc View 1 chunk +1 line, -1 line 0 comments Download
M runtime/vm/code_generator.cc View 2 chunks +2 lines, -2 lines 0 comments Download
M runtime/vm/dart.cc View 2 chunks +2 lines, -2 lines 0 comments Download
M runtime/vm/dart_api_impl.h View 1 chunk +2 lines, -2 lines 0 comments Download
M runtime/vm/dart_api_state.h View 1 chunk +2 lines, -2 lines 0 comments Download
M runtime/vm/growable_array.h View 2 chunks +3 lines, -3 lines 0 comments Download
M runtime/vm/isolate.h View 1 chunk +1 line, -1 line 0 comments Download
M runtime/vm/isolate.cc View 4 chunks +4 lines, -4 lines 0 comments Download
M runtime/vm/native_entry.h View 1 2 chunks +3 lines, -3 lines 0 comments Download
M runtime/vm/object.cc View 3 chunks +3 lines, -3 lines 0 comments Download
M runtime/vm/raw_object_snapshot.cc View 1 chunk +1 line, -1 line 0 comments Download
M runtime/vm/runtime_entry.h View 1 chunk +1 line, -1 line 0 comments Download
M runtime/vm/snapshot_test.cc View 21 chunks +21 lines, -21 lines 0 comments Download
M runtime/vm/symbols.cc View 1 chunk +1 line, -1 line 0 comments Download
M runtime/vm/unit_test.h View 1 chunk +1 line, -1 line 0 comments Download
M runtime/vm/zone.h View 4 chunks +23 lines, -21 lines 0 comments Download
M runtime/vm/zone.cc View 14 chunks +18 lines, -19 lines 0 comments Download
M runtime/vm/zone_test.cc View 5 chunks +5 lines, -5 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
Tom Ball
All configurations built and tested.
8 years, 2 months ago (2012-10-05 17:31:59 UTC) #1
siva
lgtm https://chromiumcodereview.appspot.com/11040062/diff/1/runtime/vm/dart_api_state.h File runtime/vm/dart_api_state.h (right): https://chromiumcodereview.appspot.com/11040062/diff/1/runtime/vm/dart_api_state.h#newcode65 runtime/vm/dart_api_state.h:65: Zone* GetBaseZone() { return &zone_; } Should we ...
8 years, 2 months ago (2012-10-05 18:31:58 UTC) #2
Tom Ball
8 years, 2 months ago (2012-10-05 18:55:47 UTC) #3
http://codereview.chromium.org/11040062/diff/1/runtime/vm/dart_api_state.h
File runtime/vm/dart_api_state.h (right):

http://codereview.chromium.org/11040062/diff/1/runtime/vm/dart_api_state.h#ne...
runtime/vm/dart_api_state.h:65: Zone* GetBaseZone() { return &zone_; }
On 2012/10/05 18:31:58, siva wrote:
> Should we also rename the getter to GetZone() ?

Definitely.  I left it in there to make catching references to it easier for the
next CL (they're already gone in my local client :-).

http://codereview.chromium.org/11040062/diff/1/runtime/vm/growable_array.h
File runtime/vm/growable_array.h (right):

http://codereview.chromium.org/11040062/diff/1/runtime/vm/growable_array.h#ne...
runtime/vm/growable_array.h:91: Zone* zone_;  // Zone in which we are allocating
the array.
On 2012/10/05 18:31:58, siva wrote:
> For this case we end up including a handles block which is not going to be
used
> at all. I haven't looked at what the overhead of that is, we may need to watch
> this as GrowableArray is used a lot in the VM.

Okay, I'll keep an eye out for issues there.

http://codereview.chromium.org/11040062/diff/1/runtime/vm/native_entry.h
File runtime/vm/native_entry.h (right):

http://codereview.chromium.org/11040062/diff/1/runtime/vm/native_entry.h#newc...
runtime/vm/native_entry.h:35: void
NATIVE_ENTRY_FUNCTION(name)(Dart_NativeArguments args) {         \
On 2012/10/05 18:31:58, siva wrote:
> Not related to your change but could you adjust the indentation of the '\' on
> this line.

Done.

http://codereview.chromium.org/11040062/diff/1/runtime/vm/zone.h
File runtime/vm/zone.h (right):

http://codereview.chromium.org/11040062/diff/1/runtime/vm/zone.h#newcode167
runtime/vm/zone.h:167: Zone* GetBaseZone() { return &zone_; }
On 2012/10/05 18:31:58, siva wrote:
> ditto question about renaming this to GetZone
Done in next CL.

Powered by Google App Engine
This is Rietveld 408576698