Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(10)

Unified Diff: client/dom/templates/html/frog/impl_EventTarget.darttemplate

Issue 9845043: Rename client/{dom,html} to lib/{dom,html} . (Closed) Base URL: http://dart.googlecode.com/svn/branches/bleeding_edge/dart/
Patch Set: Created 8 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: client/dom/templates/html/frog/impl_EventTarget.darttemplate
===================================================================
--- client/dom/templates/html/frog/impl_EventTarget.darttemplate (revision 5796)
+++ client/dom/templates/html/frog/impl_EventTarget.darttemplate (working copy)
@@ -1,63 +0,0 @@
-// Copyright (c) 2012, the Dart project authors. Please see the AUTHORS file
-// for details. All rights reserved. Use of this source code is governed by a
-// BSD-style license that can be found in the LICENSE file.
-
-class _EventsImpl implements Events {
- /* Raw event target. */
- // TODO(jacobr): it would be nice if we could specify this as
- // _EventTargetImpl or EventTarget
- final var _ptr;
-
- _EventsImpl(this._ptr);
-
- _EventListenerListImpl operator [](String type) => _get(type.toLowerCase());
-
- _EventListenerListImpl _get(String type) {
- return new _EventListenerListImpl(_ptr, type);
- }
-}
-
-class _EventListenerListImpl implements EventListenerList {
-
- // TODO(jacobr): make this _EventTargetImpl
- final var _ptr;
- final String _type;
-
- _EventListenerListImpl(this._ptr, this._type);
-
- // TODO(jacobr): implement equals.
-
- _EventListenerListImpl add(EventListener listener,
- [bool useCapture = false]) {
- _add(listener, useCapture);
- return this;
- }
-
- _EventListenerListImpl remove(EventListener listener,
- [bool useCapture = false]) {
- _remove(listener, useCapture);
- return this;
- }
-
- bool dispatch(Event evt) {
- // TODO(jacobr): what is the correct behavior here. We could alternately
- // force the event to have the expected type.
- assert(evt.type == _type);
- return _ptr._dispatchEvent(evt);
- }
-
- void _add(EventListener listener, bool useCapture) {
- _ptr._addEventListener(_type, listener, useCapture);
- }
-
- void _remove(EventListener listener, bool useCapture) {
- _ptr._removeEventListener(_type, listener, useCapture);
- }
-}
-
-
-class $CLASSNAME$EXTENDS$IMPLEMENTS$NATIVESPEC {
-
- Events get on() => new _EventsImpl(this);
-$!MEMBERS
-}

Powered by Google App Engine
This is Rietveld 408576698