Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(200)

Issue 9173001: Make heap size estimation more accurate. (Closed)

Created:
8 years, 11 months ago by Michael Starzinger
Modified:
8 years, 11 months ago
CC:
v8-dev
Visibility:
Public.

Description

Make heap size estimation more accurate. This improves the heap size estimation by not counting lazy swept pages as completely allocated but use their live bytes counter instead. R=vegorov@chromium.org BUG=v8:1893 TEST=cctest/test-heap/TestSizeOfObjects Committed: http://code.google.com/p/v8/source/detail?r=10383

Patch Set 1 #

Patch Set 2 : Improved test case to do exact checking. #

Total comments: 2

Patch Set 3 : Addressed comments by Vyacheslav Egorov. #

Total comments: 4

Patch Set 4 : Addressed more comments by Vyacheslav Egorov. #

Unified diffs Side-by-side diffs Delta from patch set Stats (+61 lines, -7 lines) Patch
M src/mark-compact.cc View 1 2 3 1 chunk +1 line, -0 lines 0 comments Download
M src/spaces.h View 1 2 3 4 chunks +19 lines, -6 lines 0 comments Download
M src/spaces.cc View 1 2 3 3 chunks +4 lines, -1 line 0 comments Download
M test/cctest/test-heap.cc View 1 2 1 chunk +37 lines, -0 lines 0 comments Download

Messages

Total messages: 5 (0 generated)
Michael Starzinger
8 years, 11 months ago (2012-01-10 12:51:16 UTC) #1
Vyacheslav Egorov (Chromium)
http://codereview.chromium.org/9173001/diff/3001/src/spaces.cc File src/spaces.cc (right): http://codereview.chromium.org/9173001/diff/3001/src/spaces.cc#newcode752 src/spaces.cc:752: intptr_t PagedSpace::SizeOfObjectsSlow() { we will call this function at ...
8 years, 11 months ago (2012-01-10 17:42:43 UTC) #2
Michael Starzinger
PTAL. http://codereview.chromium.org/9173001/diff/3001/src/spaces.cc File src/spaces.cc (right): http://codereview.chromium.org/9173001/diff/3001/src/spaces.cc#newcode752 src/spaces.cc:752: intptr_t PagedSpace::SizeOfObjectsSlow() { On 2012/01/10 17:42:43, Vyacheslav Egorov ...
8 years, 11 months ago (2012-01-11 09:55:57 UTC) #3
Vyacheslav Egorov (Chromium)
LGTM! http://codereview.chromium.org/9173001/diff/11001/src/mark-compact.cc File src/mark-compact.cc (right): http://codereview.chromium.org/9173001/diff/11001/src/mark-compact.cc#newcode3644 src/mark-compact.cc:3644: space->MarkPageForLazySweep(p); I would call it MarkPageForLazySweeping http://codereview.chromium.org/9173001/diff/11001/src/spaces.h File ...
8 years, 11 months ago (2012-01-11 10:16:49 UTC) #4
Michael Starzinger
8 years, 11 months ago (2012-01-11 10:34:00 UTC) #5
Added new patch set. Landed.

http://codereview.chromium.org/9173001/diff/11001/src/mark-compact.cc
File src/mark-compact.cc (right):

http://codereview.chromium.org/9173001/diff/11001/src/mark-compact.cc#newcode...
src/mark-compact.cc:3644: space->MarkPageForLazySweep(p);
On 2012/01/11 10:16:49, Vyacheslav Egorov wrote:
> I would call it MarkPageForLazySweeping

Done.

http://codereview.chromium.org/9173001/diff/11001/src/spaces.h
File src/spaces.h (right):

http://codereview.chromium.org/9173001/diff/11001/src/spaces.h#newcode1663
src/spaces.h:1663: intptr_t unswept_dead_bytes_;
On 2012/01/11 10:16:49, Vyacheslav Egorov wrote:
> I would call them free not dead (I think object can be dead but not the byte).

Done.

Powered by Google App Engine
This is Rietveld 408576698