OLD | NEW |
1 // Copyright (c) 2011 The Chromium Authors. All rights reserved. | 1 // Copyright (c) 2011 The Chromium Authors. All rights reserved. |
2 // Use of this source code is governed by a BSD-style license that can be | 2 // Use of this source code is governed by a BSD-style license that can be |
3 // found in the LICENSE file. | 3 // found in the LICENSE file. |
4 | 4 |
5 #include "chrome/browser/sync/engine/process_commit_response_command.h" | 5 #include "chrome/browser/sync/engine/process_commit_response_command.h" |
6 | 6 |
7 #include <set> | 7 #include <set> |
8 #include <string> | 8 #include <string> |
9 #include <vector> | 9 #include <vector> |
10 | 10 |
11 #include "base/basictypes.h" | 11 #include "base/basictypes.h" |
12 #include "base/tracked.h" | 12 #include "base/location.h" |
13 #include "chrome/browser/sync/engine/syncer_proto_util.h" | 13 #include "chrome/browser/sync/engine/syncer_proto_util.h" |
14 #include "chrome/browser/sync/engine/syncer_util.h" | 14 #include "chrome/browser/sync/engine/syncer_util.h" |
15 #include "chrome/browser/sync/engine/syncproto.h" | 15 #include "chrome/browser/sync/engine/syncproto.h" |
16 #include "chrome/browser/sync/sessions/sync_session.h" | 16 #include "chrome/browser/sync/sessions/sync_session.h" |
17 #include "chrome/browser/sync/syncable/directory_manager.h" | 17 #include "chrome/browser/sync/syncable/directory_manager.h" |
18 #include "chrome/browser/sync/syncable/syncable.h" | 18 #include "chrome/browser/sync/syncable/syncable.h" |
19 | 19 |
20 using syncable::ScopedDirLookup; | 20 using syncable::ScopedDirLookup; |
21 using syncable::WriteTransaction; | 21 using syncable::WriteTransaction; |
22 using syncable::MutableEntry; | 22 using syncable::MutableEntry; |
(...skipping 459 matching lines...) Expand 10 before | Expand all | Expand 10 after Loading... |
482 // been recursively deleted. | 482 // been recursively deleted. |
483 // TODO(nick): Here, commit_message.deleted() would be more correct than | 483 // TODO(nick): Here, commit_message.deleted() would be more correct than |
484 // local_entry->Get(IS_DEL). For example, an item could be renamed, and then | 484 // local_entry->Get(IS_DEL). For example, an item could be renamed, and then |
485 // deleted during the commit of the rename. Unit test & fix. | 485 // deleted during the commit of the rename. Unit test & fix. |
486 if (local_entry->Get(IS_DIR) && local_entry->Get(IS_DEL)) { | 486 if (local_entry->Get(IS_DIR) && local_entry->Get(IS_DEL)) { |
487 deleted_folders->insert(local_entry->Get(ID)); | 487 deleted_folders->insert(local_entry->Get(ID)); |
488 } | 488 } |
489 } | 489 } |
490 | 490 |
491 } // namespace browser_sync | 491 } // namespace browser_sync |
OLD | NEW |