Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1179)

Issue 7879: Introduce a lookup cache class in the runtime system and use it for... (Closed)

Created:
12 years, 2 months ago by Mads Ager (chromium)
Modified:
9 years, 7 months ago
Reviewers:
bak
CC:
v8-dev
Visibility:
Public.

Description

Introduce a lookup cache class in the runtime system and use it for keyed loads that enter the runtime. Committed: http://code.google.com/p/v8/source/detail?r=561

Patch Set 1 #

Unified diffs Side-by-side diffs Delta from patch set Stats (+195 lines, -27 lines) Patch
M src/heap.h View 2 chunks +7 lines, -1 line 0 comments Download
M src/heap.cc View 2 chunks +4 lines, -0 lines 1 comment Download
M src/heap-inl.h View 1 chunk +20 lines, -0 lines 1 comment Download
M src/objects.h View 3 chunks +22 lines, -0 lines 0 comments Download
M src/objects.cc View 6 chunks +89 lines, -13 lines 2 comments Download
M src/objects-inl.h View 2 chunks +6 lines, -0 lines 0 comments Download
M src/runtime.cc View 2 chunks +47 lines, -13 lines 1 comment Download

Messages

Total messages: 2 (0 generated)
Mads Ager (chromium)
12 years, 2 months ago (2008-10-22 20:18:28 UTC) #1
bak
12 years, 2 months ago (2008-10-23 06:08:11 UTC) #2
LGTM,
  Lars

http://codereview.chromium.org/7879/diff/1/4
File src/heap-inl.h (right):

http://codereview.chromium.org/7879/diff/1/4#newcode173
Line 173: }
Use keyed_lookup_cache() instead of keyed_lookup_cache_.

http://codereview.chromium.org/7879/diff/1/2
File src/heap.cc (right):

http://codereview.chromium.org/7879/diff/1/2#newcode1199
Line 1199: // Initialize keyed lookup cache.
Use ClearKeyedLookupCache();

http://codereview.chromium.org/7879/diff/1/3
File src/objects.cc (right):

http://codereview.chromium.org/7879/diff/1/3#newcode5885
Line 5885: virtual bool IsMatch(Object* other) {
Why do you use the virtual keyword in this class?
Please make it consistent with SymbolsKey etc.

http://codereview.chromium.org/7879/diff/1/3#newcode5958
Line 5958: if (entry != -1) {
I find this easier to read.
if (entry == -1) return -1;
return Smi::cast(get(EntryToIndex(entry) + 1))->value();

http://codereview.chromium.org/7879/diff/1/5
File src/runtime.cc (right):

http://codereview.chromium.org/7879/diff/1/5#newcode1694
Line 1694: int offset = cache->Lookup(receiver_map, key);
It might be a good idea to use a kNotFound constant for -1.

Powered by Google App Engine
This is Rietveld 408576698