Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(470)

Issue 7863: - Optimized CopyFixedArray and CopyJSObject. (Closed)

Created:
12 years, 2 months ago by bak
Modified:
9 years, 7 months ago
Reviewers:
Kasper Lund
CC:
v8-dev
Visibility:
Public.

Description

- Optimized CopyFixedArray and CopyJSObject. - Refactored block copying. Committed: http://code.google.com/p/v8/source/detail?r=548

Patch Set 1 #

Unified diffs Side-by-side diffs Delta from patch set Stats (+105 lines, -85 lines) Patch
M src/codegen-arm.cc View 1 chunk +1 line, -1 line 0 comments Download
M src/codegen-ia32.cc View 1 chunk +1 line, -1 line 0 comments Download
M src/handles.h View 1 chunk +1 line, -1 line 0 comments Download
M src/handles.cc View 1 chunk +2 lines, -2 lines 0 comments Download
M src/heap.h View 2 chunks +8 lines, -0 lines 0 comments Download
M src/heap.cc View 5 chunks +54 lines, -22 lines 2 comments Download
M src/heap-inl.h View 1 chunk +19 lines, -0 lines 0 comments Download
M src/objects.h View 3 chunks +1 line, -9 lines 1 comment Download
M src/objects.cc View 1 chunk +0 lines, -27 lines 0 comments Download
M src/objects-inl.h View 3 chunks +15 lines, -17 lines 0 comments Download
M src/runtime.cc View 1 chunk +1 line, -1 line 0 comments Download
M src/spaces-inl.h View 1 chunk +1 line, -3 lines 0 comments Download
M test/cctest/test-heap.cc View 1 chunk +1 line, -1 line 0 comments Download

Messages

Total messages: 2 (0 generated)
bak
12 years, 2 months ago (2008-10-22 08:06:50 UTC) #1
Kasper Lund
12 years, 2 months ago (2008-10-22 08:17:21 UTC) #2
LGTM.

http://codereview.chromium.org/7863/diff/1/4
File src/heap.cc (right):

http://codereview.chromium.org/7863/diff/1/4#newcode1765
Line 1765: Object* clone =  new_space_.AllocateRaw(object_size);
Extra space before new_space_.

http://codereview.chromium.org/7863/diff/1/4#newcode1778
Line 1778: Object* elem =  Heap::CopyFixedArray(elements);
Extra space before Heap.

http://codereview.chromium.org/7863/diff/1/9
File src/objects.h (right):

http://codereview.chromium.org/7863/diff/1/9#newcode815
Line 815: static inline Failure* RetryAfterGC(int requested_bytes);  //
NEW_SPACE
How about renaming this to avoid the overloading? Something like
RetryAfterNewSpaceGC might do the trick? Then you could also get rid of the
comment.

Powered by Google App Engine
This is Rietveld 408576698