Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1202)

Unified Diff: base/value_conversions.h

Issue 7461141: Rename BASE_API to BASE_EXPORT. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src/
Patch Set: '' Created 9 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « base/utf_string_conversions.h ('k') | base/values.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: base/value_conversions.h
===================================================================
--- base/value_conversions.h (revision 95578)
+++ base/value_conversions.h (working copy)
@@ -8,7 +8,7 @@
// This file contains methods to convert a |FilePath| to a |Value| and back.
-#include "base/base_api.h"
+#include "base/base_export.h"
class FilePath;
@@ -18,8 +18,8 @@
class Value;
// The caller takes ownership of the returned value.
-BASE_API StringValue* CreateFilePathValue(const FilePath& in_value);
-BASE_API bool GetValueAsFilePath(const Value& value, FilePath* file_path);
+BASE_EXPORT StringValue* CreateFilePathValue(const FilePath& in_value);
+BASE_EXPORT bool GetValueAsFilePath(const Value& value, FilePath* file_path);
} // namespace
« no previous file with comments | « base/utf_string_conversions.h ('k') | base/values.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698