Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1866)

Unified Diff: base/tracked.h

Issue 7461141: Rename BASE_API to BASE_EXPORT. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src/
Patch Set: '' Created 9 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « base/timer.h ('k') | base/tracked.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: base/tracked.h
===================================================================
--- base/tracked.h (revision 95578)
+++ base/tracked.h (working copy)
@@ -21,7 +21,7 @@
#include <string>
-#include "base/base_api.h"
+#include "base/base_export.h"
#include "base/time.h"
#ifndef NDEBUG
@@ -36,7 +36,7 @@
// Location provides basic info where of an object was constructed, or was
// significantly brought to life.
-class BASE_API Location {
+class BASE_EXPORT Location {
public:
// Constructor should be called with a long-lived char*, such as __FILE__.
// It assumes the provided value will persist as a global constant, and it
@@ -81,7 +81,7 @@
const void* const program_counter_;
};
-BASE_API const void* GetProgramCounter();
+BASE_EXPORT const void* GetProgramCounter();
//------------------------------------------------------------------------------
// Define a macro to record the current source location.
@@ -98,7 +98,7 @@
class Births;
-class BASE_API Tracked {
+class BASE_EXPORT Tracked {
public:
Tracked();
virtual ~Tracked();
« no previous file with comments | « base/timer.h ('k') | base/tracked.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698