Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(3721)

Unified Diff: base/threading/thread_local_storage.h

Issue 7461141: Rename BASE_API to BASE_EXPORT. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src/
Patch Set: '' Created 9 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « base/threading/thread_local.h ('k') | base/threading/thread_restrictions.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: base/threading/thread_local_storage.h
===================================================================
--- base/threading/thread_local_storage.h (revision 95578)
+++ base/threading/thread_local_storage.h (working copy)
@@ -6,7 +6,7 @@
#define BASE_THREADING_THREAD_LOCAL_STORAGE_H_
#pragma once
-#include "base/base_api.h"
+#include "base/base_export.h"
#include "base/basictypes.h"
#if defined(OS_POSIX)
@@ -17,7 +17,7 @@
// Wrapper for thread local storage. This class doesn't do much except provide
// an API for portability.
-class BASE_API ThreadLocalStorage {
+class BASE_EXPORT ThreadLocalStorage {
public:
// Prototype for the TLS destructor function, which can be optionally used to
@@ -26,7 +26,7 @@
typedef void (*TLSDestructorFunc)(void* value);
// A key representing one value stored in TLS.
- class BASE_API Slot {
+ class BASE_EXPORT Slot {
public:
explicit Slot(TLSDestructorFunc destructor = NULL);
« no previous file with comments | « base/threading/thread_local.h ('k') | base/threading/thread_restrictions.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698