Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(3215)

Unified Diff: base/task_queue.h

Issue 7461141: Rename BASE_API to BASE_EXPORT. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src/
Patch Set: '' Created 9 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « base/task.h ('k') | base/third_party/nspr/prtime.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: base/task_queue.h
===================================================================
--- base/task_queue.h (revision 95578)
+++ base/task_queue.h (working copy)
@@ -8,13 +8,13 @@
#include <deque>
-#include "base/base_api.h"
+#include "base/base_export.h"
#include "base/task.h"
// A TaskQueue is a queue of tasks waiting to be run. To run the tasks, call
// the Run method. A task queue is itself a Task so that it can be placed in a
// message loop or another task queue.
-class BASE_API TaskQueue : public Task {
+class BASE_EXPORT TaskQueue : public Task {
public:
TaskQueue();
virtual ~TaskQueue();
« no previous file with comments | « base/task.h ('k') | base/third_party/nspr/prtime.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698