Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1032)

Unified Diff: base/synchronization/cancellation_flag.h

Issue 7461141: Rename BASE_API to BASE_EXPORT. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src/
Patch Set: '' Created 9 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « base/sync_socket.h ('k') | base/synchronization/condition_variable.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: base/synchronization/cancellation_flag.h
===================================================================
--- base/synchronization/cancellation_flag.h (revision 95578)
+++ base/synchronization/cancellation_flag.h (working copy)
@@ -6,7 +6,7 @@
#define BASE_SYNCHRONIZATION_CANCELLATION_FLAG_H_
#pragma once
-#include "base/base_api.h"
+#include "base/base_export.h"
#include "base/atomicops.h"
#include "base/threading/platform_thread.h"
@@ -17,7 +17,7 @@
// is thread-safe.
//
// This class IS NOT intended for synchronization between threads.
-class BASE_API CancellationFlag {
+class BASE_EXPORT CancellationFlag {
public:
CancellationFlag() : flag_(false) {
#if !defined(NDEBUG)
« no previous file with comments | « base/sync_socket.h ('k') | base/synchronization/condition_variable.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698