Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(3364)

Unified Diff: base/string_piece.h

Issue 7461141: Rename BASE_API to BASE_EXPORT. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src/
Patch Set: '' Created 9 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « base/string_number_conversions.h ('k') | base/string_split.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: base/string_piece.h
===================================================================
--- base/string_piece.h (revision 95578)
+++ base/string_piece.h (working copy)
@@ -21,12 +21,12 @@
#include <string>
-#include "base/base_api.h"
+#include "base/base_export.h"
#include "base/basictypes.h"
namespace base {
-class BASE_API StringPiece {
+class BASE_EXPORT StringPiece {
public:
// standard STL container boilerplate
typedef size_t size_type;
@@ -164,7 +164,7 @@
size_type length_;
};
-BASE_API bool operator==(const StringPiece& x, const StringPiece& y);
+BASE_EXPORT bool operator==(const StringPiece& x, const StringPiece& y);
inline bool operator!=(const StringPiece& x, const StringPiece& y) {
return !(x == y);
« no previous file with comments | « base/string_number_conversions.h ('k') | base/string_split.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698