Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1791)

Unified Diff: base/message_loop_proxy_impl.h

Issue 7461141: Rename BASE_API to BASE_EXPORT. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src/
Patch Set: '' Created 9 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « base/message_loop_proxy.h ('k') | base/message_pump.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: base/message_loop_proxy_impl.h
===================================================================
--- base/message_loop_proxy_impl.h (revision 95578)
+++ base/message_loop_proxy_impl.h (working copy)
@@ -6,7 +6,7 @@
#define BASE_MESSAGE_LOOP_PROXY_IMPL_H_
#pragma once
-#include "base/base_api.h"
+#include "base/base_export.h"
#include "base/message_loop.h"
#include "base/message_loop_proxy.h"
#include "base/synchronization/lock.h"
@@ -16,8 +16,9 @@
// A stock implementation of MessageLoopProxy that takes in a MessageLoop
// and keeps track of its lifetime using the MessageLoop DestructionObserver.
// For now a MessageLoopProxyImpl can only be created for the current thread.
-class BASE_API MessageLoopProxyImpl : public MessageLoopProxy,
- public MessageLoop::DestructionObserver {
+class BASE_EXPORT MessageLoopProxyImpl
+ : public MessageLoopProxy,
+ public MessageLoop::DestructionObserver {
public:
virtual ~MessageLoopProxyImpl();
« no previous file with comments | « base/message_loop_proxy.h ('k') | base/message_pump.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698