Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(65)

Unified Diff: base/files/file_path_watcher.h

Issue 7461141: Rename BASE_API to BASE_EXPORT. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src/
Patch Set: '' Created 9 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « base/file_version_info_win.h ('k') | base/global_descriptors_posix.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: base/files/file_path_watcher.h
===================================================================
--- base/files/file_path_watcher.h (revision 95578)
+++ base/files/file_path_watcher.h (working copy)
@@ -8,7 +8,7 @@
#define BASE_FILES_FILE_PATH_WATCHER_H_
#pragma once
-#include "base/base_api.h"
+#include "base/base_export.h"
#include "base/basictypes.h"
#include "base/file_path.h"
#include "base/memory/ref_counted.h"
@@ -26,7 +26,7 @@
// detect the creation and deletion of files in a watched directory, but will
// not detect modifications to those files. See file_path_watcher_mac.cc for
// details.
-class BASE_API FilePathWatcher {
+class BASE_EXPORT FilePathWatcher {
public:
// Declares the callback client code implements to receive notifications. Note
// that implementations of this interface should not keep a reference to the
« no previous file with comments | « base/file_version_info_win.h ('k') | base/global_descriptors_posix.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698