Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(165)

Unified Diff: base/event_recorder.h

Issue 7461141: Rename BASE_API to BASE_EXPORT. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src/
Patch Set: '' Created 9 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « base/environment.h ('k') | base/file_descriptor_shuffle.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: base/event_recorder.h
===================================================================
--- base/event_recorder.h (revision 95578)
+++ base/event_recorder.h (working copy)
@@ -6,7 +6,7 @@
#define BASE_EVENT_RECORDER_H_
#pragma once
-#include "base/base_api.h"
+#include "base/base_export.h"
#include "base/basictypes.h"
#include "build/build_config.h"
@@ -33,7 +33,7 @@
// Why? Imagine if the product had a "record a macro" feature.
// You might be recording globally, while recording or playing back
// a macro. I don't think two playbacks make sense.
-class BASE_API EventRecorder {
+class BASE_EXPORT EventRecorder {
public:
// Get the singleton EventRecorder.
// We can only handle one recorder/player at a time.
« no previous file with comments | « base/environment.h ('k') | base/file_descriptor_shuffle.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698