Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(128)

Issue 7390032: Fixes regression from menu refactoring. The old windows code wasn't (Closed)

Created:
9 years, 5 months ago by sky
Modified:
9 years, 5 months ago
Reviewers:
oshima
CC:
chromium-reviews, dhollowa
Visibility:
Public.

Description

Fixes regression from menu refactoring. The old windows code wasn't correctly listening to capture change, so that once I wired it up it exposed a bug. I need to suppress capture change notification when hiding a menu, otherwise it prematurely triggers cancelling menus. BUG=89594 TEST=see bug, also covered by automated tests now. R=oshima@chromium.org Committed: http://src.chromium.org/viewvc/chrome?view=rev&revision=93029

Patch Set 1 #

Total comments: 2

Patch Set 2 : Rename field #

Unified diffs Side-by-side diffs Delta from patch set Stats (+52 lines, -6 lines) Patch
M chrome/browser/ui/views/bookmarks/bookmark_bar_view_test.cc View 1 chunk +44 lines, -0 lines 0 comments Download
M views/controls/menu/menu_host.h View 1 1 chunk +2 lines, -2 lines 0 comments Download
M views/controls/menu/menu_host.cc View 1 4 chunks +6 lines, -4 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
sky
9 years, 5 months ago (2011-07-18 17:04:39 UTC) #1
oshima
LGTM with a nit. http://codereview.chromium.org/7390032/diff/1/views/controls/menu/menu_host.h File views/controls/menu/menu_host.h (right): http://codereview.chromium.org/7390032/diff/1/views/controls/menu/menu_host.h#newcode77 views/controls/menu/menu_host.h:77: bool showing_or_hiding_; Looking at how ...
9 years, 5 months ago (2011-07-18 18:18:04 UTC) #2
sky
9 years, 5 months ago (2011-07-18 21:43:28 UTC) #3
http://codereview.chromium.org/7390032/diff/1/views/controls/menu/menu_host.h
File views/controls/menu/menu_host.h (right):

http://codereview.chromium.org/7390032/diff/1/views/controls/menu/menu_host.h...
views/controls/menu/menu_host.h:77: bool showing_or_hiding_;
On 2011/07/18 18:18:04, oshima wrote:
> Looking at how this is used, i think "ignore_capture_lost_" or something like
is
> easier to understand. What do you think?

Done.

Powered by Google App Engine
This is Rietveld 408576698