Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1090)

Issue 7349005: Added dictionary that can use objects as keys. (Closed)

Created:
9 years, 5 months ago by Michael Starzinger (Google)
Modified:
9 years, 5 months ago
CC:
v8-dev
Visibility:
Public.

Description

Added dictionary that can use objects as keys. R=vegorov@chromium.org TEST=cctest/test-dictionary Committed: http://code.google.com/p/v8/source/detail?r=8619

Patch Set 1 #

Total comments: 2

Patch Set 2 : Incorporated review from Vyacheslav Egorov. #

Total comments: 2

Patch Set 3 : Added unit test to gyp buildfile as well. #

Unified diffs Side-by-side diffs Delta from patch set Stats (+225 lines, -64 lines) Patch
M src/api.cc View 1 chunk +1 line, -33 lines 0 comments Download
M src/handles.h View 1 chunk +2 lines, -0 lines 0 comments Download
M src/handles.cc View 1 chunk +6 lines, -30 lines 0 comments Download
M src/objects.h View 1 2 chunks +28 lines, -0 lines 0 comments Download
M src/objects.cc View 1 5 chunks +97 lines, -1 line 0 comments Download
M src/objects-inl.h View 1 1 chunk +26 lines, -0 lines 0 comments Download
M test/cctest/SConscript View 1 chunk +1 line, -0 lines 0 comments Download
M test/cctest/cctest.gyp View 1 2 1 chunk +1 line, -0 lines 0 comments Download
A test/cctest/test-dictionary.cc View 1 1 chunk +63 lines, -0 lines 0 comments Download

Messages

Total messages: 5 (0 generated)
Michael Starzinger (Google)
This re-factors the GetIdentityHash implementation into the internal API and adds a simplistic unit test ...
9 years, 5 months ago (2011-07-12 09:46:45 UTC) #1
Vyacheslav Egorov (Chromium)
http://codereview.chromium.org/7349005/diff/1/src/objects-inl.h File src/objects-inl.h (right): http://codereview.chromium.org/7349005/diff/1/src/objects-inl.h#newcode4313 src/objects-inl.h:4313: if (maybe_hash->IsFailure()) return 0; If we are trying to ...
9 years, 5 months ago (2011-07-12 10:42:07 UTC) #2
Michael Starzinger (Google)
Thanks for the review. Incorporated suggested changes.
9 years, 5 months ago (2011-07-12 11:50:19 UTC) #3
Vyacheslav Egorov (Chromium)
LGTM http://codereview.chromium.org/7349005/diff/4001/src/objects.cc File src/objects.cc (right): http://codereview.chromium.org/7349005/diff/4001/src/objects.cc#newcode11535 src/objects.cc:11535: MaybeObject* ObjectDictionary::AddChecked(JSObject* key, Object* value) { AddChecked is ...
9 years, 5 months ago (2011-07-12 13:30:32 UTC) #4
Michael Starzinger (Google)
9 years, 5 months ago (2011-07-12 15:05:06 UTC) #5
http://codereview.chromium.org/7349005/diff/4001/src/objects.cc
File src/objects.cc (right):

http://codereview.chromium.org/7349005/diff/4001/src/objects.cc#newcode11535
src/objects.cc:11535: MaybeObject* ObjectDictionary::AddChecked(JSObject* key,
Object* value) {
Maybe we can come up with a better name once we actually use it aside from the
unit test.

On 2011/07/12 13:30:32, Vyacheslav Egorov wrote:
> AddChecked is a bit confusing name but I can't invent a better name.
> HashKeyAndAdd might be better but it's still pretty confusing.

Powered by Google App Engine
This is Rietveld 408576698