Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(60)

Issue 7206038: Correctly handle non-array receivers in Array length setter. (Closed)

Created:
9 years, 6 months ago by Mads Ager (chromium)
Modified:
9 years, 6 months ago
Reviewers:
Rico
CC:
v8-dev
Visibility:
Public.

Description

Correctly handle non-array receivers in Array length setter. BUG=v8:1491 TEST=mjsunit/regress/regress-1491.js Committed: http://code.google.com/p/v8/source/detail?r=8343

Patch Set 1 #

Total comments: 2
Unified diffs Side-by-side diffs Delta from patch set Stats (+48 lines, -13 lines) Patch
M src/accessors.cc View 2 chunks +10 lines, -13 lines 0 comments Download
A test/mjsunit/regress/regress-1491.js View 1 chunk +38 lines, -0 lines 2 comments Download

Messages

Total messages: 3 (0 generated)
Mads Ager (chromium)
9 years, 6 months ago (2011-06-21 07:41:39 UTC) #1
Rico
LGTM http://codereview.chromium.org/7206038/diff/1/test/mjsunit/regress/regress-1491.js File test/mjsunit/regress/regress-1491.js (right): http://codereview.chromium.org/7206038/diff/1/test/mjsunit/regress/regress-1491.js#newcode37 test/mjsunit/regress/regress-1491.js:37: o.length = value; Maybe add assertDoesNotThrow around the ...
9 years, 6 months ago (2011-06-21 07:54:39 UTC) #2
Mads Ager (chromium)
9 years, 6 months ago (2011-06-21 08:00:43 UTC) #3
http://codereview.chromium.org/7206038/diff/1/test/mjsunit/regress/regress-14...
File test/mjsunit/regress/regress-1491.js (right):

http://codereview.chromium.org/7206038/diff/1/test/mjsunit/regress/regress-14...
test/mjsunit/regress/regress-1491.js:37: o.length = value;
On 2011/06/21 07:54:39, Rico wrote:
> Maybe add assertDoesNotThrow around the assignment to explicitly catch the
issue
> stated in the bug report (we will fail anyway, but it is more readable what we
> are trying to assert).

I'd like to keep it the way it is. I think asserting that we do not throw will
just make the test harder to read. The assert that the correct thing was written
is really what we want and any uncaught exceptions in this code (and all other
tests) is a failure.

Powered by Google App Engine
This is Rietveld 408576698