Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(41)

Issue 6660023: Initialize zone lists in the register allocator with more reasonable initial ... (Closed)

Created:
9 years, 9 months ago by fschneider
Modified:
9 years, 6 months ago
CC:
v8-dev
Visibility:
Public.

Description

Initialize zone lists in the register allocator with more reasonable initial capacities. Also replace fixed length zone lists with embedded vectors for the fixed live ranges. Committed: http://code.google.com/p/v8/source/detail?r=7122

Patch Set 1 #

Total comments: 2
Unified diffs Side-by-side diffs Delta from patch set Stats (+30 lines, -32 lines) Patch
M src/hydrogen.cc View 1 chunk +2 lines, -2 lines 0 comments Download
M src/lithium-allocator.h View 3 chunks +7 lines, -20 lines 2 comments Download
M src/lithium-allocator.cc View 4 chunks +21 lines, -10 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
fschneider
9 years, 9 months ago (2011-03-10 10:44:52 UTC) #1
Kevin Millikin (Chromium)
LGTM. http://codereview.chromium.org/6660023/diff/1/src/lithium-allocator.h File src/lithium-allocator.h (right): http://codereview.chromium.org/6660023/diff/1/src/lithium-allocator.h#newcode604 src/lithium-allocator.h:604: EmbeddedVector<LiveRange*, No matter what you do here, it ...
9 years, 9 months ago (2011-03-10 11:23:08 UTC) #2
fschneider
9 years, 9 months ago (2011-03-10 12:04:16 UTC) #3
http://codereview.chromium.org/6660023/diff/1/src/lithium-allocator.h
File src/lithium-allocator.h (right):

http://codereview.chromium.org/6660023/diff/1/src/lithium-allocator.h#newcode604
src/lithium-allocator.h:604: EmbeddedVector<LiveRange*,
On 2011/03/10 11:23:08, Kevin Millikin wrote:
> No matter what you do here, it will be a nasty line break.  I like to break at
> the lowest precedence operator that makes it fit on the fewest lines.  Here,
the
> lowest precedence ought to be the space between the type and identifier:
> 
> EmbeddedVector<LiveRange*, Register::kNumAllocatableRegisters>
>     fixed_live_ranges_;
> 
> I like that a little better, but what do you think?

I'm fine with both.

Powered by Google App Engine
This is Rietveld 408576698