Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(585)

Issue 6542017: Minor refactoring: unify lazy function compilation for in loop and no in loop variants. (Closed)

Created:
9 years, 10 months ago by antonm
Modified:
9 years, 4 months ago
CC:
v8-dev
Visibility:
Public.

Description

Minor refactoring: unify lazy function compilation for in loop and no in loop variants. Committed: http://code.google.com/p/v8/source/detail?r=6873

Patch Set 1 #

Total comments: 2

Patch Set 2 : Switching to enum #

Unified diffs Side-by-side diffs Delta from patch set Stats (+11 lines, -16 lines) Patch
M src/handles.cc View 1 2 chunks +11 lines, -16 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
antonm
Kevin, another tiny review for you
9 years, 10 months ago (2011-02-18 15:03:40 UTC) #1
Kevin Millikin (Chromium)
LGTM, nice cleanup. http://codereview.chromium.org/6542017/diff/1/src/handles.cc File src/handles.cc (right): http://codereview.chromium.org/6542017/diff/1/src/handles.cc#newcode859 src/handles.cc:859: return CompileLazyFunction(function, flag, false /* in ...
9 years, 10 months ago (2011-02-18 16:16:58 UTC) #2
antonm
9 years, 10 months ago (2011-02-21 18:27:58 UTC) #3
Thanks a lot for review and suggestions, guys.  Submitting

http://codereview.chromium.org/6542017/diff/1/src/handles.cc
File src/handles.cc (right):

http://codereview.chromium.org/6542017/diff/1/src/handles.cc#newcode859
src/handles.cc:859: return CompileLazyFunction(function, flag, false /* in loop
*/);
(And responding to Slava too): I didn't want to introduce new enum, but then
recalled we already have this IN_LOOP/NOT_IN_LOOP stuff, switched to it.

On 2011/02/18 16:16:58, Kevin Millikin wrote:
> The C style comment is OK, but I don't think we have any examples of the style
> in the code already:
> 
> You could also consider:
> 
> const kInLoop = false;
> return CompileLazyFunction(function, flag, kInLoop);
> 
> but it's not obviously better.

Powered by Google App Engine
This is Rietveld 408576698