Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(280)

Issue 6538080: Add template parameter for hydrogen input operands. (Closed)

Created:
9 years, 10 months ago by fschneider
Modified:
9 years, 6 months ago
CC:
v8-dev
Visibility:
Public.

Description

Patch Set 1 #

Patch Set 2 : HIR refactoring. #

Total comments: 4

Patch Set 3 : added other platforms #

Unified diffs Side-by-side diffs Delta from patch set Stats (+404 lines, -500 lines) Patch
M src/arm/lithium-arm.h View 1 2 4 chunks +32 lines, -36 lines 0 comments Download
M src/arm/lithium-arm.cc View 1 2 3 chunks +20 lines, -2 lines 0 comments Download
M src/hydrogen.h View 1 1 chunk +1 line, -1 line 0 comments Download
M src/hydrogen.cc View 1 15 chunks +21 lines, -16 lines 0 comments Download
M src/hydrogen-instructions.h View 1 2 45 chunks +210 lines, -328 lines 0 comments Download
M src/hydrogen-instructions.cc View 1 10 chunks +31 lines, -41 lines 0 comments Download
M src/ia32/lithium-ia32.h View 1 2 6 chunks +15 lines, -33 lines 0 comments Download
M src/ia32/lithium-ia32.cc View 1 3 chunks +20 lines, -2 lines 0 comments Download
M src/x64/lithium-x64.h View 1 2 5 chunks +34 lines, -39 lines 0 comments Download
M src/x64/lithium-x64.cc View 1 2 3 chunks +20 lines, -2 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
fschneider
9 years, 10 months ago (2011-02-22 13:11:39 UTC) #1
Kevin Millikin (Chromium)
LGTM. http://codereview.chromium.org/6538080/diff/5001/src/hydrogen-instructions.h File src/hydrogen-instructions.h (right): http://codereview.chromium.org/6538080/diff/5001/src/hydrogen-instructions.h#newcode725 src/hydrogen-instructions.h:725: class HOperandContainer { This is essentially the same ...
9 years, 10 months ago (2011-02-22 15:00:39 UTC) #2
fschneider
9 years, 10 months ago (2011-02-23 10:42:18 UTC) #3
http://codereview.chromium.org/6538080/diff/5001/src/hydrogen-instructions.h
File src/hydrogen-instructions.h (right):

http://codereview.chromium.org/6538080/diff/5001/src/hydrogen-instructions.h#...
src/hydrogen-instructions.h:725: class HOperandContainer {
On 2011/02/22 15:00:39, Kevin Millikin wrote:
> This is essentially the same as the corresponding Lithium container.  Let's
> consider adding to utils a generic EmbeddedContainer template class
> parameterized over type and length.

I agree - for that I need to factor out the printing functionality from the
lithium-version of the OperandContainer. It seemed like a too big change to at
once, so I'll do it separately.

http://codereview.chromium.org/6538080/diff/5001/src/hydrogen-instructions.h#...
src/hydrogen-instructions.h:728: for (int i = 0; i < NumElements; i++) elems_[i]
= NULL;
On 2011/02/22 15:00:39, Kevin Millikin wrote:
> We should be able to zero initialize the elems_ by naming it in the
initializer
> list:
> 
> HOperandContainer() : elems_() { }
> 
> I've started using that style, so there is precedent.

Done. (but somehow I don't trust all compilers to do the right thing...)

Powered by Google App Engine
This is Rietveld 408576698