Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(302)

Issue 6072003: PPB_Class simple test. (Closed)

Created:
10 years ago by neb
Modified:
9 years, 7 months ago
Reviewers:
polina, brettw
CC:
chromium-reviews
Visibility:
Public.

Description

PPB_Class simple test. BUG=none TEST=none Committed: http://src.chromium.org/viewvc/chrome?view=rev&revision=70778

Patch Set 1 #

Total comments: 6

Patch Set 2 : Polinas comments and lint. #

Unified diffs Side-by-side diffs Delta from patch set Stats (+84 lines, -0 lines) Patch
M ppapi/ppapi.gyp View 1 1 chunk +2 lines, -0 lines 0 comments Download
A ppapi/tests/test_class.h View 1 1 chunk +32 lines, -0 lines 0 comments Download
A ppapi/tests/test_class.cc View 1 1 chunk +50 lines, -0 lines 0 comments Download

Messages

Total messages: 5 (0 generated)
neb
10 years ago (2010-12-20 20:14:05 UTC) #1
brettw
LGTM
10 years ago (2010-12-20 20:20:54 UTC) #2
polina
http://codereview.chromium.org/6072003/diff/1/ppapi/tests/test_class.cc File ppapi/tests/test_class.cc (right): http://codereview.chromium.org/6072003/diff/1/ppapi/tests/test_class.cc#newcode21 ppapi/tests/test_class.cc:21: class_interface_ = reinterpret_cast<PPB_Class const*>( const PPB_Class* ? http://codereview.chromium.org/6072003/diff/1/ppapi/tests/test_class.cc#newcode48 ppapi/tests/test_class.cc:48: ...
10 years ago (2010-12-21 03:43:28 UTC) #3
neb
http://codereview.chromium.org/6072003/diff/1/ppapi/tests/test_class.cc File ppapi/tests/test_class.cc (right): http://codereview.chromium.org/6072003/diff/1/ppapi/tests/test_class.cc#newcode21 ppapi/tests/test_class.cc:21: class_interface_ = reinterpret_cast<PPB_Class const*>( On 2010/12/21 03:43:28, polina wrote: ...
9 years, 11 months ago (2011-01-05 23:51:09 UTC) #4
polina
9 years, 11 months ago (2011-01-06 21:19:04 UTC) #5
lgtm

On 2011/01/05 23:51:09, neb wrote:
> http://codereview.chromium.org/6072003/diff/1/ppapi/tests/test_class.cc
> File ppapi/tests/test_class.cc (right):
> 
>
http://codereview.chromium.org/6072003/diff/1/ppapi/tests/test_class.cc#newco...
> ppapi/tests/test_class.cc:21: class_interface_ = reinterpret_cast<PPB_Class
> const*>(
> On 2010/12/21 03:43:28, polina wrote:
> > const PPB_Class* ?
> 
> It means the same thing so long it's on the left side of *. I changed it to
> const PPB_Class* it's easier to read.
> 
>
http://codereview.chromium.org/6072003/diff/1/ppapi/tests/test_class.cc#newco...
> ppapi/tests/test_class.cc:48: return std::string();
> On 2010/12/21 03:43:28, polina wrote:
> > return ""
> > would be more readable
> 
> "" is not a string, so this would be calling an implicit constructor. Can we
> keep it explicit, even if it's a bit more verbose?
> 
> http://codereview.chromium.org/6072003/diff/1/ppapi/tests/test_class.h
> File ppapi/tests/test_class.h (right):
> 
>
http://codereview.chromium.org/6072003/diff/1/ppapi/tests/test_class.h#newcode5
> ppapi/tests/test_class.h:5: #ifndef PPAPI_TEST_TEST_CLASS_H_
> On 2010/12/21 03:43:28, polina wrote:
> > s/TEST_TEST/TESTS_TEST/
> 
> Done. Again, great eye.

Powered by Google App Engine
This is Rietveld 408576698